Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Before you redirect me, I checked all other topics I could find, but none of them had the same issue as I do. First of all, I bought the PS3 controller from eBay and I have a strong feeling that it's fake. Thtat's probably my fault, but I wouldn't care as long as I could link it to my Pi3.

    I was following steps of linking the controller to Pi3, but as soon as I plugged the controller to Pi3 to pair it, it started vibrating and did not stop untill I unplugged it again. I was then supposed to pair it by clicking the PS button, but all 4 lights on controller kept blinking and it did not pair. I also tried all 4 drivers for PS3 (the official one + 3 others that were listed there).

    I know there is obviously something wrong with my controller, I am just wondering whether there is a solution how to fix it. I read that using reset button on controller could help, but as I tried to use it, it's not there. There is just a hole, no button.

    I have already received a refund from seller, I am just wondering if I should throw it right into trash can or not.


  • @Spiky that hole is the reset button. Put a toothpick in it and push the button. But yeah there are fake ps3 controllers everywhere. Having spent so many years in the video game business i have seen bootlegs of everything. First thing is the sticker on the back. If it isnt straight or bubbled it is fake. If you look at the sticker of a real one they look different too. If it says anything different than DC3.7V 300mA on the sticker it is 100% fake. The 4 blinking lights, if you run your finger across them and you can feel them sticking out and probably not smooth it is a fake. If you shine a flashlight on a real one and look at the sony logo, select and start and look at them from an angle they should be a light blue or light purple depending on how your eyes perceive color. Bootlegs are usually gray.


  • @edmaul69 I will check the details you described when I come home. About the reset button... there really is none. I used flashlight to look inside and I could see the board inside, so there was no button to press.


  • @Spiky well that would be a definite sign of a bootleg.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.