Please do not post a support request without first reading and following the advice in

Sharing internet connection to PI via ethernet

  • Good morning,

    I have just bought my Pi3 b Raspberry starter kit, and last night I fired it up with the latest Retropie.
    The system works right, and I managed to play a few games as well.
    However, I still lack internet connection.
    Here's my network setup: my Windows PC connects via a very powerful AP to the router, which is placed on the other side of my house. Wifi signal is quite poor, and the Pi will therefore not be able to get it. Repeaters are a no-go, so I thought I could "share" py PC's wifi connection with the Pi via direct ethernet connection.
    My wifi connection, on Windows 10, is configured to allow other network users to share internet connection.
    This works quite well with my PS3, but does not seem to be so straightforward, with Pi and Retropie. I tried rebooting, but no luck.
    Is there a particular piece of configuration I should try, to obtain this? (I am not home at the moment, but I shall try getting a log as soon as I get back)

    Many thanks in advance to anyone who can help me ;)

  • Ok, I'm still not giving up on this.
    As far as I know, everything is configured correctly, so here's what I did these days:

    • I changed my ethernet cable, so to check it was not faulty, with one I knew to be perfecly working.
    • I set up network sharing for my wifi connection on my Windows 10 partition, but no joy. SSH access worked fine, but I got no internet connection. I tried setting a bridged connection between my WiFi and my ethernet cards, without any success: again, I got no internet connection.
    • I rebooted to my Ubuntu partition (same PC), set up network sharing on the same wifi connection, and Retropie succesfully connected to the internet via direct ethernet cable connection to my PC. This way, I knew everything was working as it should, at least on my raspberry PI3 b. I took the occasion to do a dist-update, taking up a few hours, due to heavy network traffic...all went fine, anyway.
    • I went back to my Windows 10 partition, I spent over one hour uninstalling and reinstalling different versions of all the drivers for both my Wifi connection and my ethernet one. Rebooted at least six times both the PC and the raspberry, then went back to previously installed drivers for the network connections, reconfigured my wifi access and its sharing options via device manager, rebooted once again...and my Raspberry suddenly started connecting via ethernet as it should have! All was working, if a little slowly.
    • I experimented a little bit, scraped a few roms, etc., then shut everything off and went to bed.
    • Next day, I turned on again my PC on its windows partition and, to my absolute dismay, wifi sharing via direct ethernet cable connection was working no more... :(
    • I tried setting a fixed IP to the ethernet connection: I set up it to, netmask, gateway (that's my PC IP address). Windows network connection then shows the ethernet as connected to internet, yet this way SSH does not work and, of course, the raspberry does not get internet access at all...

    I am frankly at a loss...any chance I might be missing something on the above?
    Many thanks to anyone shading a light this way...

  • Another two days, and still no joy on Windows.
    I just read HERE, however, that installation of Apple Bonjour is recommended as a way to help the raspberry Pi getting an IP, when connecting it via direct ethernet cable on Windows...I don't really remember if I have already installed Bonjour or not...I will check tonight, anyway, and see if installing/reinstalling it does the trick.
    I'm still open to suggestions, eh...don't be a stranger, if you know something I might have missed. ;)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.