Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Subfolders Not Working After Upgrade



  • I am having issues with sub-folders after upgrading. I have roms in my PSX and Dreamcast folders that have multiple files. In previous versions of Retropie this worked fine and the games launched. Over the weekend @pjft and I worked on ES modifications to allow the metadata and video preview to work with these subfolders as well. After updating to 4.2 I am not able to launch any games that are in sub folders. I tried this in the base ES install as well as the modified ES install, so i believe it has something to do with the 4.2 upgrade? Any ideas? Thanks



  • @TMNTturtlguy thanks for following this. The first question is: do you confirm that they were working prior to the upgrade?

    If so, my guess is that it has nothing to do with ES but rather I suspect it could be related to the runcommand launch script overhaul that took place for 4.2.

    Can you get the content of the runcommand log after trying to launch one game in a sub folder?

    I don't know the location by heart but it shows on launch.

    Just do

    less /tmp/runcommand.log
    

    Or wherever it states it's logging things to on the launch window.

    Best.


  • Global Moderator

    @pjft

    Or wherever it states it's logging things to on the launch window.

    I believe it's /dev/shm/runcommand.log



  • @mediamogul YES! That is the path. Thanks



  • @pjft Yes, I can confirm that prior to upgrading to 4.2 the subfolders worked in both the base ES and the ES that we worked on over the weekend. I was able to have the multiple rom files within a folder. I could then enter PSX, have video preview and meta data at the first screen. I selected a game title, went to a second screen where only that game title was displayed. Select that game title and launch the game. Now with the 4.2 upgrade on the base ES V2.1.5RP the video and metadata show on the first screen when entering PSX, but the system trys to launch directly from the first folder, instead of opening to the second folder and then launching. The log says unsupported/invalid cd image. I assure you this launched fine and nothing has changed with the ROMs since upgrading from 4.19.

    Here is the log, running Retropie 4.2 with ES V2.1.5RP
    Parameters:
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-pcsx-rearmed/libretro.so --config /opt/retropie/configs/psx/retroarch.cfg "/home/pi/RetroPie/roms/psx/Batman & Robin" --appendconfig /dev/shm/retroarch.cfg
    Starting PCSX-ReARMed
    Running PCSX Version 1.9 (Mar 9 2017).
    psxMap: warning: wanted to map @80000000, got 0x740ce000
    Init new dynarec
    testing if we can run recompiled code..
    test passed.
    warning: RAM is not directly mapped, performance will suffer
    Mapped (RAM/scrp/ROM/LUTs/TC):
    77000000/1f800000/1fc00000/08000000/74d13000
    found BIOS file: SCPH1001.BIN
    RGB565 supported, using it
    plugin: plugins/builtin_gpu
    plugin: plugins/builtin_spu
    plugin: plugins/builtin_pad
    plugin: plugins/builtin_pad
    Plugins loaded.
    Loaded CD Image: /home/pi/RetroPie/roms/psx/Batman & Robin.
    selected sound output driver: libretro
    unsupported/invalid CD image: /home/pi/RetroPie/roms/psx/Batman & Robin



  • @pjft I figured out the issue. If you set "ParseGamelistOnly" to on in the menu, or True in the es_settings.cfg it causes the issue. I will try to be clear in my description:

    Parse Gameslist Only = Off (false) - Everything works just fine with the folders, launching games, video preview, metadata. This is the case in both the base ES and in the screensaver version.

    Parse Gameslist Only = ON (True) - Now games that are within folders will not launch. All the video previews and meta data still work, however the run command tries to launch from the base folder instead of opening the folder. This is the case in both the base ES and in the screensaver version.

    I went back to retropie 4.19 and this same instance occurred. This is not something we tested as we worked on getting the videos and meta data to work with the folders. I believe this is an ES setting and not a retropie setting. When parse gameslist only is set on, it only looks to the gamelist, and since the main folder is in the gamelist, and not the executable file for the rom, it will not work correctly.

    Thanks



  • @TMNTturtlguy Well, that explains that. :)

    I suppose you'll need to have the actual rom files in the gamelist for the option to Parse Gamelist Only to work for that case.



  • @pjft Yeah, i will have to do some thinking on this one. I am glad it was something so simple and not something I missed while testing out all of the configurations! If you put the rom name into the gamelist the mail folder won't have any images/videos/metadata, so that won't work well either. The other thing I am going to look into is how to hide folders from the list. I have looked around threads and haven't come up with a solution. I am thinking of trying to see if there is a way to add the folders i don't want to see, like the bios folders, to the gamelist, and then tell the gamelist not to display that game/folder. Kind of like how you can # in the .txt files to turn things on and off. Any thoughts on that?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.

Looks like your connection to RetroPie Forum was lost, please wait while we try to reconnect.