Please do not post a support request without first reading and following the advice in

Announcing Pegasus Frontend

  • @halfmanhalfcake Oh, didn't know Steam had such feature. Will check it out, thanks.

  • This week there have been a large amount of internal changes. It shouldn't have any visible effects, but in some cases, you might perhaps see a slight performance improvement.

  • Weekly changelog!

    • Fixed game launching (which I accidentally broke last week)
    • Fixed Raspberry build sometimes not uploading correctly
    • A number of mouse, touchscreen and Android related improvements
      • The main menu and the default theme is now fully usable with only mouse or touch too
      • Game launching confirmed working on Android - expect the documentation this afternoon
      • Video playback now works on Android
      • Config files on Android are now stored under <storage>/pegasus-frontend, where storage is the internal storage if you have one, otherwise the SD card. (Previously configs were stored in some internal system dir)
      • The package version is now displayed correctly in the Android settings menu
    • Minor fixes

    I've also made a video:

  • @fluffypillow Probably the coolest thing I've seen in a long time.

  • Update: The Android docs are now online here.

  • Just updated to latest version, after a long break away from my arcade build - but now Pegasus won't launch. The splash screen is replaced with the text about locales, games found and after the last line stating how many games are found, nothing else happens... Does not respond to inputs either.

    Does the newest version require something like a special version of RetroPie installed or..?

    Edit: a few hints maybe; it states;
    QQmlApplicationEngine failed to load component
    qrc:/frontend/main.qml:101 Type MenuOverlay unavailable
    qrc:/frontend/menuoverlay.qml:122 Type SettingsScreen unavailable
    qrc:/frontend/menu/SettingsScreen.qml:85 Type MultivalueOption unavailable
    qrc:/frontend/menu/settings/MultivalueOption.qml:78 Cannot assign to non-existent property "cursorShape"

  • @andershp Thanks, that's a bug, I'll fix it right away.

  • @andershp Ok, should be fixed now!

  • @fluffypillow Sure is! Thanks!

  • I started writing a small frontend chooser app:


  • Hi :) @fluffypillow

    I recently tried to test your app on android, but I was unable to make the roms shows up :/, tried everything but with no success.
    I did make the config file and test various path but nothing, test the internal on external drive. I'm pretty that I followed carefully the config guide.

    Keep up the good work, and thanks in advance if you have any suggestion.

  • @fluffypillow said in Announcing Pegasus Frontend:

    I started writing a small frontend chooser app:

    Oh meohmy. :) This looks wonderful.

  • @seya16 Hm, do you see anything interesting in the log file (<pegasus-dir>/lastrun.log)? If possible, try to open it directly on the device with some text editor app (files tend to be out of sync when I open them on desktop, at least for me).

    Yeah, I should really start working on some file picker instead of the manual editing...

  • @fluffypillow It show this :
    Found locale 'American English' (en)
    Found locale 'español de España' (es)
    Found locale 'français' (fr)
    Found locale 'magyar' (hu)
    Found locale 'magyar (rovás)' (hu-Hung)
    Locale set to 'American English' (en)
    Found theme 'Pegasus Grid [built-in]' (:/themes/pegasus-grid/)
    Theme set to 'Pegasus Grid [built-in]' (:/themes/pegasus-grid/)
    Found /storage/emulated/0/pegasus-frontend/game_dirs.txt
    ES2: system config file not found
    Data files loaded in 13ms
    0 games found
    Closing Pegasus, goodbye!

    But yeah I think that a file picker will be really useful :)

  • @seya16 it seems like /storage/emulated/0/pegasus-frontend/game_dirs.txt was found, but the directories listed in it were not, or don't contain collection files (collections.txt or collections.pegasus.txt). Do the paths and files exist?

  • @fluffypillow yes
    And just so you know I did test it on two different android devices (the GPD XD with android 4.4 and Huwei P9 lite with android Nougat) and the result is the same....

  • @seya16 Hmm, I'll add some more verbose logging then, to see what could be the error. Also thanks for testing on multiple devices!

  • The newest version ruined the favorites filter for me.

    My previously dedicated favorites from EmulationStation have a heart in the game info screen alright, but when ticking the filterbox, no games show up. Ticking the multiplayer box seems to be ok, but not favorites, not even if I reassign some new games.

  • @andershp Hm that's interesting, will check it. Do you know the last version where it was working correctly?

  • @fluffypillow Ah, sorry, I don't really know. My previous update was around where PageUp/Down was introduced.
    Right now I'm on alpha7-99-gafcfb69 (pretty sure it's the latest - updated a few days ago).

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.