Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Disable/reverse the right stick up/down stock invert for libretro-tyrquake?



  • Hi guys.

    I'm guessing this is an easy fix, but i'm not well versed enough to figure it out on my own.As always i only ask as a last resort, i've already tried for a good 2hrs to do this myself to no avail.Monkeying around in the retroarch gui, in the quake controls menu, and adding lines to the quake retroarch.cfg but nothing works.

    Stock out of the box libretro-tyrquake has great controls for a 360 controller....except the right stick used for looking around, confusingly, has right stick up as look down, and right stick down as look up (aka invert).

    This is dumb.

    I realize i can use the 4 face buttons a b x y to look up and down and turn left and right but surely there must be a way to disable the invert on the right stick?



  • @megafacehead the only way i could get it to work was to swap +2 and -2 in the controllers specific config. but that messes up the control for other systems. for me it completely ignored the /ports/quake/retroarch.cfg even though the emulators.cfg points to it. you can try it yourself if you want. open /opt/retropie/configs/ports/quake/retroarch.cfg and add this above the #include... line:

    input_player1_r_x_plus = "+2"
    input_player1_r_x_minus = "-2"
    input_player1_r_y_plus = "-3"
    input_player1_r_y_minus = "+3"
    


  • Ok, cool, good to know i'm not an idiot cause i already tried that myself, that's why i resorted to asking on here, hat in hand.

    Well that really sucks.Pretty much puts quake in the bin for me, i cant play with inverted look( don't know how anyone does short of flying sims) and the face button look alternative is really not great at all.

    Oh well. If anyone lurkers have some ideas would be great to hear em.Thanks anyways edmaul69.



  • Hey

    Was mucking around trying random settings in the ports\quake\retroarch.cfg and this actually ended up working.

    input_player1_r_y_minus_axis = "+3"
    input_player1_r_y_plus_axis = "-3
    

    Thanks again edmaul69, i only got this to work by taking what you'd posted, comparing what the xbox controller format uses(they had _axis at the end of it's commands and then tried random numbers lol. Watch out boys, Neo here, hacking the matrix lol.

    tldr-

    Don't like the stock invert in libretro-tyrquake on the right stick?
    Add this to your ports\quake\retroarch.cfg

    input_player1_r_y_minus_axis = "+3"
    input_player1_r_y_plus_axis = "-3
    

    above the line that says
    #include "/opt/retropie/configs/all/retroarch.cfg"

    to make right stick-up look up and right stick-down look down.



  • @megafacehead man i feel stupid. I knew that too. I mess with changing stuff from axis and btn all the time. How i forgot im not sure.



  • Better option is to bring up the retroarch menu (select + top button) then go to "Quick Menu > Options" and set "Invert Y Axis" to "Enabled".



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.