Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Gamecon driver no longer working in Retropie 4.2.2



  • Pi2 @ 1Ghz
    Multibootpi with Retropie 4.0.x upgraded to 4.2.2 c1c78c5

    I've had this problem in the past where the driver failed to install on previous upgrades of Retropie, but updating all packages, rebooting, and repeating the process 2-3x always used to fix it. I tried a clean install of the same distro and then upgraded to 4.2.2 again, but I get the same results.

    "Error! Bad return status for module build on kernel: 4.9.24-v7+ (armv7l)"
    The rest of the errors are in the pastebin.

    https://pastebin.com/iJguArsD


  • administrators

    @Darksavior you didn't update OS packages / kernel.


  • administrators

    oh wait. sorry. no the problem is you have installed a bleeding edge kernel - did you use rpi-update ? It won't work with that. You need to install a packaged kernel.



  • @BuZz I've only used the "Update All Installed Packages" option and nothing more. I also do press Yes in updating "the underlying OS packages (eg kernel etc) option".


  • administrators

    Please confirm the output of uname -a from a terminal.

    If you have a 4.9.x kernel installed, then you have at some point used rpi-update or are using an image that someone else used that on. I just noticed you are using Multibootpi - This is not an official image and it's reasons like this official images are not supported (as they are often modified).

    Use our official image. You can also try sudo apt-get install --reinstall raspberrypi-kernel to get the packaged kernel back on.



  • @BuZz I can confirm it's using 4.9.24-v7. This multibootpi image is from october 2016 and originally included 4.0.x and has never given me issues before. I'll try a new fresh image and report back.


  • administrators

    @Darksavior 4.9.24 was only released 7 days ago, so if you didn't use rpi-update, that image must have some script to update it or something (or it's not using Raspbian but another custom disto).



  • @BuZz
    Ok, I installed a fresh official 4.2 image and updated that to 4.2.2 with nothing but the retropie script updater...annnnnd its 4.9.24-v7 and the gamecon driver stopped working. I did install the gamecon driver without updating a thing when it was in 4.2 and of course, that worked.

    I did try that command to get the packaged kernel back annnnd: "unpacking raspberrypi -kernel (1.20170427-1) over (1.20170427.-1)...


  • administrators

    @Darksavior OK. Looks like they have now packaged 4.9.x - I hadn't realised sorry. I can only recommend you don't update the kernel for now then, as the gamecon driver is not yet compatible with 4.9 and I don't have time right now to look into it. (3rd party package so will need an upstream fix).



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.