@ehindy Do you have samba enabled? That's what makes it pop up on your network. I rather use a client to transfer like winscp or flashfxp. If you wish to go that route, enable ssh in raspi-config and insert the pi's ip with port 22 and login/pass of pi/raspberry in client.