Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

lr-fba v0.2.97.39 bug: OutRun, A.B. Cop, Akranoid, After Burner II, etc... no digital control!



  • It appears that the lr-fba core (v0.2.97.39 build e2a7b83) does not accept digital direction inputs. Previous builds worked without issues and so does fba2012.

    It's definitely a bug and it only applies to games that use analogue inputs (wheels or joysticks). Is this the appropriate forum or should I inform the libretro team about this?

    Also the windows version of the core seems to be OK so it's only evident in RetroPie.


  • Global Moderator

    @matchaman

    Is this the appropriate forum or should I inform the libretro team about this?

    There might be few people who can weigh in on this issue here, but it can be better handled by reporting it to the libretro team directly.



  • I will do that in a moment, I hope they won't bounce me back :/



  • I'm bumping this because I found a solution. It's not the best possible thing to do but seems to have solved my issue.

    I edited my .cfg file on /opt/retropie/configs/all/retroarch/autoconfig and added

    input_l_y_minus_axis = "-1"
    input_l_x_plus_axis = "+0"
    input_l_y_plus_axis = "+1"
    input_l_x_minus_axis = "-0"

    in order to set the digital inputs as analogue (in addition to keeping them as analogue too).

    It appears that the current fba core accepts only analogue (thumb)stick inputs for arcade machines that used analogue hardware such as wheels, joysticks, pedals, etc, something that wasn't a case previously and still isn't on MAME.

    For anyone having the same problem (and doesn't use analogue sticks) this seems to be the only solution currently but I'm not sure if this will interfere with anything else.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.