Please do not post a support request without first reading and following the advice in

Retropie 4.2 freezes with official power supply

  • Hi, I have previously used a +5V 1.5A power supply (from some Android device) with my RPi3 (model B / v1.2), which worked ok, games started up nicely, but the lightning bolt symbol was always present and some video+sound issues in some games (especially N64 + SNES).. Most emulators ran very nicely however.. I decided to invest in an official RPi PSU (+5.1V 2.5A) power supply, which solved the "lighting bolt" issue, but now it freezes the retropie starting a game (doesn't matter which emulator/game) and sometimes even at the menu..
    So does anyone know what causes this, or how to fix it?
    I obviously thought that the 2.5A PSU would help RPi3 run better than with the 1.5A PSU
    Current version running is 4.2, iBuffalo SNES controller + USB-Stick 8GB attached..

  • It's hard to say if you have the proper power supply. Maybe check your power cable. I use an extra long one and keep that in mind when I am troubleshooting. Maybe your Pi or new power supply is malfunctioning. Do you have a second Pi to test your current card?

    Since it's global it sounds like you might need to do some additional troubleshooting. I would almost reinstall with a fresh image on the SD card (or a different one) to rule out the SD card, image & configuration. Maybe a different USB drive if that's what you're using.

    It seems there's a lot that could happening to make a determination or if it was a larger/build related issue more would be posting.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.