Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PSX - Oddworld Abe's Exoddus (crash at loading screen)



  • I can run the game from emulationstation. The cinematic runs fine and I get into the game. But when I get to the first "secret /bonus room" and enter a door - I get to the first loading screen, and it just gets stuck. Waited for 15min now :) and happened 3 times. The sound keeps playing though, and not like it's stuck.

    Could this be some failure with my whole RetroPie setup? Or is it the game image file?

    This is the file I downloaded: [removed]

    My Setup:
    Device: Raspberry PI 3 model b
    Emulator: lr-pcsx-rearmed
    Bios: SCPH1001.BIN

    Has anyone else got it to work?

    Could overclocking help anything? Or does anyone have a small hint of things I could do?

    EDIT: I have now tried out another rom. And the problem still occurs.
    EDIT2: Now I tried to just skip the bonus room, and I kept playing for more than an hour. Until I get to a new door, where I get the same loading freeze.
    EDIT3: I have now tried to play the game on my Ubuntu computer with PCSX emulator, where the game runs fine. So it is not a case of bad rom.
    EDIT4: I have now also tried to use the pcsx-rearmed emulator. But with this I can't seem to get any of my games started :/


  • administrators



  • You should try with SCPH101.BIN bios instead. It's the one from PSOne, so it's more modern and updated and generally should work better (at least that's the case with my games I've tested). Also, try disabling some features like Interlacing and Dithering.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.