Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[Solved] Trackball not working after 4.3 update



  • Hello there, forgive me if I make any mistakes in posting this. Here is my situation: I updated from 4.2 to 4.3 on my raspberry pi 3 yesterday. I use a ultimac trackball, and before the update everything was working fine for my mame 2003 roms, but now the games have no response to the trackball. This is disappointing because I use my arcade mainly to play centipede and now I have to use the joysticks. I don't want to move to another emulator because all my configurations are set using mame 2003, including overlays. If there isn't an immediate solution, is there at least a way I can downgrade back to 4.2? Everything worked fine for me on that version.



  • @majin-wamu Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first



  • @majin-wamu At first I was going to reply that everything is fine with my trackball, but then I tried a game with for my spinners and they don't work at all.

    Yeah, something is definitely wrong after the update. Do you happen to have another mouse device on your system by any chance? I have two: my Ultimarc U-Trak and a second mouse interface for my two spinners. The spinners share a single input (split x and y). For me, my trackball works fine, but my spinners no longer work in lr-mame2003. Prior to this update, 2003 had mouse input where all mouse devices could work. Of course, that meant that if you wanted two, you were out of luck as they all were working as one. I also had to re-enable the core option for mame2003-dialsharexy = "enabled".

    @dankcushions you probably know the history about this better than anyone. Do you think this has something to do with the new mame2003-mouse_device = "pointer" core option addition? Now only one mouse device works for analog input.

    For the record:
    Pi3, RetroPie 4.2 official, upgraded to 4.3 (all packages), Adafruit power adapter (the good one 5.1v), Powered USB hub with IPAC4, Utrak, GGG TurboTwist spinners, Happ sticks backlit pushbuttons, 19" LCD. Aww heck, you can see all this in my signature.
    Emulator: lr-mame2003
    issue: it only works with one mouse device now.



  • @caver01 I have tried using a mouse as a substitute, and it wouldn't respond either. It is quite a disappointment.
    I am going to try to make that adjustment you mention about the "dialsharexy", I know for a fact I haven't ever checked that setting.
    To make sure nothing is wrong with my hardware, I flashed 4.2 on another SD card, and tested everything, and it works fine. The reason why I won't stick with it is because it doesn't have all the customization and settings as I do with my primary. Plus my primary is a 64 gb while the secondary is a 32 gb and I have plans to attach it to a cocktail cabinet. Plus my customization would take me a very long time to recover on the secondary.



  • @majin-wamu sharexy will not fix your trackball. That is for splitting a single set of axes to player 1 and 2 for spinners in a game like Blasteroids.

    My question was whether you had more than one mouse device connected. On my system, my trackball works fine, but my spinners do not work anymore. I was expecting that it is only selecting the first mouse device and ignoring others.



  • @caver01 Oh sorry, I only have one trackball plugged in.
    Actually let me tell you everything I have plugged in:
    *USB hub, which has it's own adapter.
    *a mini-pac for the inputs
    *ultimarc trackball
    *speakers which only use usb for power

    I believe that is it. I will open it up later today to see if I missed anything, but I believe that is all I have plugged in.



  • @majin-wamu Interesting. Well, the Minipac does have TWO interfaces. From the Ultimarc Website:

    "Inputs for one 2-axis device (trackball) and one single-axis device (spinner)."

    I wonder if lr-mame2003 is picking up the spinner interface and ignoring the trackball in your case.



  • @dankcushions @markwkidd Something definitely works differently now in lr-mame2003. I would suggest we regressed. I haven't tested the right-stick core option yet, but something tells me this won't help the way I want/need it to. For those of us who have multiple mouse inputs, how do I make my spinners work for Blasteroids, for example, while my trackball works for Centipede? I might have to revert to using AdvanceMame to get my spinners working again, and @Majin-Wamu will have to stop using 2003 for trackball games.

    Any ideas? I think I am coming late to the party, as it had been a while since I updated to the latest versions of the binaries. It could be a months-old change to lr-mame2003 that I am only just seeing now with RetroPie 4.3.



  • @caver01 Thank you caver! This is really helpful. Yeah, in the meantime I will wait it out. The version of Centipede I have doesn't seem to work with other emulators, so I can be patient. I was a little sad at the time, but I trust that the issue will be fixed eventually because the trackball worked before the 4.3 update.



  • @caver01 Hello Caver, please let me know if there are new developments or if you hear back from anyone. Or if there is anything I can do or anyone I can contact.



  • @majin-wamu The folks who might know details have been tagged here. Not much else we can do. You could try AdvanceMAME.



  • @caver01 & @Majin-Wamu is there a way either of you could start an Issue in the mame2003-libretro github tracker? Optimally with a log.

    This may be something that the libretro developer casdevel could take a look at unless dankcushions appears with an answer. casdevel is an expert on the libretro input system but they don't seem to read forums much, so I'll be glad to tag them if we can move this discussion to github



  • @markwkidd That sounds like a great idea, but if you can, since I haven't done it before, explain how I can. I do have a github account but never took the time to use it or learn can be done with it.



  • @majin-wamu you can install AdvanceMAME using the Retropie configuration menus. It will take some work to configure. Read this, and while you are at it, read the rest of RetroPie documentation.


  • Global Moderator

    i'm afraid i have no answer. i may attempt it myself, but doubtful. i've really lost track of all the mouse functionality since all the recent changes.

    an error report from someone will progress the issue.



  • @dankcushions Do you mean like something from a log? I don't think there are any errors generated, just lost functionality. I'm happy to check somewhere if it helps.



  • @caver01 said in Trackball not working after 4.3 update:

    @dankcushions Do you mean like something from a log? I don't think there are any errors generated, just lost functionality. I'm happy to check somewhere if it helps.

    The log will contain details about your mouse devices that is necessary for certain kinds of input debugging.

    That said, I have just found out that there is about to be a substantial update to the RetroArch udev input driver. It doesn't have anything specific to do with your error, but it will be worth waiting a day or two to try with the new code.

    I'll post here once that happens.



  • @markwkidd said in Trackball not working after 4.3 update:

    The log will contain details about your mouse devices that is necessary for certain kinds of input debugging.

    Where is the log that contains the relevant information? I am happy to grab it.

    I am not getting any errors, but if the log is helpful given the fact that I have two mouse devices I will pull it and share.



  • I will wait it out as well, and keeping a close eye open on this board. If the trackball had worked in the past, I don't see why it wouldn't work again in the future. The thing is, what could had possibly caused it to stop working? Like change would effect it?



  • @majin-wamu from my perspective, recent changes to mouse inputs has the emulator ignoring all but a single mouse input. In past versions, if you moved ANY attached mouse device, they all would feed input to the emulator. Of course, that meant you could not do two separate mouse devices controlling different things at the same time (like no multiplayer Rampart which has 3 trackballs), but it did allow your trackball to work in games that required it while a set of spinners worked in another game.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.