Please do not post a support request without first reading and following the advice in

Player 2 is becoming Player 1 during Game play. Need to fix

  • Rpi3, Running latest version of ES, Retroarch, and all other packages.

    So i went to /configs/all/retroarch.cfg and made sure this was setup

    input_player1_joypad_index = 1
    input_player2_joypad_index = 0

    My Player 1 controller is JS1 and Player 2 is JS0... according to the /dev/input outputs... unsure why though.

    with that said, even then with those settings, my player 2 is becoming player 1, and player 2 can only go in the hotkey menu.. player 1 cant... anyone know how to fix this??

    Just went into Retroarch menu in a rom, and went under settings > input > Input User 1 Binds

    So under Device Index, Both controllers are #1... how do i fix this?

  • @red2blue try setting them to:

    input_player1_joypad_index = 0
    input_player2_joypad_index = 1

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.