Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Controller stopped work (specific rare problem I couldn't find on google)



  • Pi Model or other hardware: RPI 3
    Power Supply used: From 2b (2Ampere)
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.3
    Built From: Pre made version from RetroPie website
    USB Devices connected: USB Stick
    Controller used: SNES USB Gamepad, Xbox 360 afterglow Wired controller, Wired Keyboard,

    Hello, first time poster here.
    I did set up my second RetroPie today when I got my hands on a Rpi3 (I have used Rpi2 previously with RetroPie).
    Everything worked perfect, from configuring controls to updating and configuring. Booting ROMs from USB stick.

    Everything worked as it was supposed this afternoon until later on the day, neither of my controllers worked in-game (they worked perfectly in menu outside of emulators).
    So I tried to go back to "Configure Input" in Main Menu of Emulationstation. 2 Gamepads detected, good.
    When I hold down a key on any controller I see "USB Gamepad" pop up for on the bottom as it should do (Same for the x360 controller). BUT! It is as if it doesn't wanna go further than 1 seconds of press and hold (It should start grayed out, and fade in more and more to become black and then I should be able to configure controls). If I hold 2 buttons, it's a little more dark, 3 button etc etc until I hold almost all buttons and then the configure works.It also works if I first hold down a button on a controller and then at the same time hold down one button on the keyboard.

    I can configure all buttons without a problem. But I have the same problem with "Press and hold to skip". The keyboard works flawless.

    I have not done ANY change whatsoever between earlier today when it worked and a few hours later when I started it up again after a break.

    What I have tried so far:
    Went to RetroPie Setup - Emulationstation config etc - Reset all input configs (so next restart I am forced to configure input the first thing), doesn't work.
    Tried 2 different SNES controller (Both have worked previously).
    Two different keyboards (Both work perfectly, one is wired, another is wireless).

    Any help appreciated, I would rather not have to do a clean sweep and start from scratch again.



  • I'm having the same problem where none of my controllers are working in game, however, I know what you're talking about, as I had that same thing (with the having to basically hold all the buttons to get it to open the remap screen) happen to me. Unfortunately, I have no idea what caused it, and I was only able to fix it by doing a clean install. If it's any consolation, since the install I haven't had that problem (just my current one where my controllers aren't working in game)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.