Please do not post a support request without first reading and following the advice in

[SOLVED] SNES (lr-snes9x-2010) freezing or going to black screen when P2 presses down ("f" key)

  • Hi all,

    I'm using the SNES (lr-snes9x-2010) emulator, and whenever Player2 presses down on the joystick (which is mapped to a keypress of the letter "f") the screen goes black. I can only see "f" printed on the screen. Pressing down ("f") again returns to normal gameplay.

    This is not expected.

    In my main retroarch.cfg I have configured things like: input_pause_toggle = nul
    I've searched the files, and I can't find any conflict with "f" defined anywhere else.

    Any help or suggestions please?


  • [SOLVED]

    I noticed that in the main retroarch.cfg file there was a setting as follows:

    # Toggles fullscreen.
    # input_toggle_fullscreen = f

    I wasn't aware that a commented line means that the "default" is still enabled. (ie: "f" is still enabled to toggle fullscreen).

    I've now changed this to the following (ie: replaced "f" with "nul") and the "problem" is now resolved:

    # Toggles fullscreen.
    input_toggle_fullscreen = nul

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.