Please do not post a support request without first reading and following the advice in

Controller works in main menu, but not in emulators.

  • In the past, I hooked up ps4 controllers, an xbox controller, a Steam Controller, Switch controller, 2 usb controllers, and a wireless remote into the pi. I think the ps4 and switch controllers used bluetooth. I tried to play a rom yesterday, and found that the remote is defaulting to player 1, and all the other controllers arent. Even if i shutdown the pi, unplug the remotes dongle, and restart it again, its still not working with any of the controllers. all of the controllers DO work on the main menu screen, and the games have the little popup in the bottom left that Detect when theyre on. I tried turning everything off and restarting the pi, with the remote and one usb controller plugged in. When i tried to do configure input on the main menu screen it told me there were 5 controllers plugged into it, but there arent. I dont understand whats going on with the controllers, but there must be a way i can change which one is player 1 right?

  • Global Moderator

    @vic3vers4 Please give more details about your system - What controller(s) do you have plugged ?

  • @mitu thanks for replying. After disconnecting everything i only have one, a usb snes styled controller. This controller has worked in emulators in the past, and works fine in emulationstation until i run a game. The problem is, the pie thinks there are more controllers plugged in (even though there isnt) and by default its setting one of them to player1.

  • Global Moderator

    @vic3vers4 When starting a game, RetroArch will display a message for each controller it detects at the bottom left of the screen (XYZ Controller detected on port #x), how many messages like this you get ?
    You can remove the existing controller configs and re-configure them in Emulationstation, then check if you get the same problem again.

  • @mitu It definitely said i have an xbox controller plugged in, they disappear before i could see what the other ones say. How do i reconfigure them in emulationstation?

  • Global Moderator

    @vic3vers4 Retropie Setup Script >> Manage Packages >> Manage Core Packages >> EmulationStation >> Configuration / Options >> Clear / Reset EmulationStation Input Configuration. This will clear all controller config from the system.
    Reboot the system, plug in one controller and then you'll be asked to configure it. Repeat for each controller you have.

  • @mitu thank you sir

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.