Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Frustrations on getting lr-mame2003 and lr-fuse to work



  • I've recently got a B+ Pi to run retropie on and got it all installed and working fine (following the first installation guide, and run updates on everything), but have hit a couple of issues that I just can't seem to get my head around to fix.

    I configured a few controllers (ps2/ps3/buffalo) through emulationstaion (v.2.7.5rp) no problem, and have installed and played various games successfully on the default emulators for Atari 2600, 7800, Megadrive and SNES.

    However my main intention for this project was for MAME games and Spectrum games, both of which I've hit a wall with.

    With Mame (lr0mame2003 using 0.78 roms) I just cannot get player 1 "start" to work with any controller. It seems setup correct in emulationstation, and all the other controls work - I can insert coins with select, and use the player2 controller to start a 2 player game, then play both players with the initial controller no problem. But I cannot figure why the start button for player1 doesn't work here. I've tried remapping it in the RGUI menu to different buttons, but nothing will get a 1 player start to register. (which works on all the emulators listed 2 paragraphs above). I've tried deleting the controller config files I found suggested somewhere else, but I'm not sure I did that right, as I later found some more config files for my controllers. Could this be causing it?

    With Spectrum (lr-fuse) the games load, but I can't do anything with them. The usb or bluetooth keyboards I have attached don't do anything, no controllers do anything, and remapping the games keys through the Select-X menu doesn't do anything.

    I'm not sure what direction to turn to try anything else to get this working, and hoped that someone on here would go "That's simple, stupid - just do this..."

    Hopefully,

    Zach



  • Typically, posting about this prompted a "duh!" moment. Changing the controller from RetroPad to Cursor Joystick or Kempston suddenly allowed the Select button to bring up the keyboard overlay. So I can now navigate menu's, and play Spectrum games with the controllers.

    Still waiting for the coin to drop (pun unintended) on the mame start button though.

    ~Z~



  • @zach in MAME you can reprogram your buttons, including the coin buttons. When a game is loaded press TAB on a keyboard, and then scroll down until you reach the coin button config. You can ten see which button is used, and if you want change it. To change to another button, highlight the coin control, press ENTER and then press whichever button you want to be Coin. Once you have changesd whichever buttons you want to, pres TAB to return to the game.



  • @douga tab on keyboard doesn't seem to do anything while in game. Is this different to the default Select-X to enter the config page?

    I've gone in here to remap keys successfully. I can change what key on the controller does what. But whatever I set to the START button for player 1 never starts a game (after pressing select to enter coins.)

    I have to add a couple of coins first, then press start on the player 2 controller to start a 2 player game. I'm unable to play a 1 player game of anything in mame, whatever controller I use or whatever I map "player 1 start' to.


  • Global Moderator

    the issue is that now you've done rebindings, it becomes difficult to undo what you've done :(

    one first step would be to delete the mame default.cfg and any other .cfgs located in the two folders listed in https://github.com/RetroPie/RetroPie-Setup/wiki/lr-mame2003#mame-menu

    after you've done that, try again. if not, we have some more cfgs to delete



  • Thanks guys - that sorted it. No idea what config files I've been finding and deleting until now, but that first location had the default.cfg and tons of seperate game ones too. Wiped them all, rebooted and mame seems to be fine now.

    Many thanks for your contributions. Case solved!

    ~Z~



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.