Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Saving failure on retropie (state + files)



  • Re: Save state failed

    Hello,

    I am very new to retropie and just set everything up. I was initially having issues saving on PSX which worked out once I installed a BIOS. After I installed the BIOS I was able to save the game but when I quit out of the game then returned to it the save file wasn't there. This issue occurs also on SNES games (which makes me assume it's system wide).

    I am also not able to use save states on any console, when I try it returns the line Save State Failed. I looked up online and on this thread: https://retropie.org.uk/forum/topic/8205/save-state-failed the individual mentioned I needed to setup directories for save files + save states for any of them to work. I initially tried to do it directly through the file system in the retropie interface but the commands didn't seem noob friendly. I then installed putty and logged into the pi from my PC with the hopes of doing it remotely but I don't see any way to browse, when I type ls all I see is retropie-Setup.

    Sorry for the noob question, I've been trying to figure it out without posting but I feel like I'm missing something.


  • Global Moderator

    On a default RP image this should work without problems. Please fill in the information requested in https://retropie.org.uk/forum/topic/3/read-this-first to better diagnose your problem.

    You can also try resetting the permissions on your ROM folders (where the saves are written), this is usually the cause of these problems - https://retropie.org.uk/docs/FAQ/#reset-ownershippermissions-of-homepiretropie-roms.



  • I purchased the Miuzei pi pack: https://www.amazon.com/gp/product/B072BXFC3V/ref=oh_aui_detailpage_o02_s01?ie=UTF8&psc=1

    Pi Model or other hardware: B+
    Power Supply used: 5V 2.5A Power Supply with Micro USB Cable
    RetroPie Version Used : 4.4
    Built From: I downloaded the image from the retropie site and formatted/burned it onto my sd card
    USB Devices connected: USB stick w/ system folders IE snes/psx/nes directories which include some rom files, also a wireless keyboard usb input, and 1 controller
    Controller used: PS4 controller
    Error messages received: While attempting to save state I receive Save State Failed. While using the in game save feature it saves and I am able to access the save unless I quit out of the game then re-enter, the save file erases/disappears
    Log found in /dev/shm/runcommand.log (if relevant):
    Guide used: Followed the retropie setup instructions on this site
    File: (File with issue - with FULL path)
    Emulator: Default PSX/SNES emulators
    Attachment of config files:
    How to replicate the problem:

    I figured in the meantime I would post this, hope to work on the issue this evening.



  • I did reset the folder permissions from the step above but the issue persists.

    I actually think I might be out of memory and that is causing the issue, I have a 32 gig sd card and I didn't think I was anywhere close to it yet.


  • Global Moderator

    @kopeacetic Exit Emulationstation and you'll see the disk space usage shown before the prompt. If you're near 100%, then you might have a disk full situation.

    Otherwise, we'll need to look at the log file. Use the Runcommand launch menu before launching the ROM and choose verbose logging, reproduce the error, then get the contents of the /dev/shm/runcommand.log file and post it on pastebin.com. We should see any errors from RetroArch in the log file.



  • @mitu

    Well after I accidentally asked the system to install retropie again through an in software menu it wouldn't even let me boot up because it said I had no memory left. I reformatted the SD card and re-flashed it and put my roms back on and everything works 100% correctly now! I'm not positive of what was actually wrong but possibly it was full of something?

    Thank you for your time and responses :D.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.