Please do not post a support request without first reading and following the advice in

EmulationStation deletes first game in gamelist

  • I just discovered a strange bug in the Windows (running on a Windows 10 64bit system) build (2.8.0RP-DEV (OCT 27 2018 - 03:13:34)) from @jdrassa.
    When I start a game, that's not the first in the gamelist, it will delete the first game entry from the list and duplicate the entry for the file that was started with the additional lastplayed and playcount info.
    For testing purposes I created a gamelist and only started the last entry. I ended up with a gamelist that only had multiple entries of that specific game. Every other entry was gone.
    A <folder> entry at the top is unaffected. I tried to start the first entry on a clean gamelist first, to see if that would change anything, but it didn't. Besides that entry wasn't duplicated, it was at the end of the xml with the lastplayed/playcount info. As it should be. After that starting a different game deleted the first entry again and the started entry was duplicated.

    Also, since I'm using the windows build to work on themes, I don't actually start games. My es_systems.cfg has just <command>something</command> as starting command. Don't know if that matters.
    Normally I have the "Save Metadata on exit" option disabled because I don't want the lastplayed/playcount info in my gamelists. But I recently activated it to test the changed <datetime> component. So I can't tell for how long this bug is around.

    I will see if I can recreate that error on a Pi on the weekend.

  • So I did some further testing.
    I can not reproduce this issue on my Pi and I can not reproduce it on different instances running on my PC.
    So it is just the instance which has an es_systems.cfg that has all available systems. And which I just use to debug a theme for all those systems.
    I thought it was because of the empty command I assigned and that ES restarted to quickly to write the updated gamelist (although that wouldn't explain why the first entry was deleted), but that made no difference when I tried it on a different instance.

    So I don't know what else I could do, but I also don't care that much because it seems to be a problem that happens just to that one instance and I can avoid it by turning the "Update Metadata on exit" off again.

  • @EctoOne said in EmulationStation deletes first game in gamelist:

    So it is just the instance which has an es_systems.cfg that has all available systems. And which I just use to debug a theme for all those systems.

    Does the bug happen there with another theme?

  • @Clyde Yeah, the theme doesn't matter.
    What I meant by "debug a theme" is when I work on a (non specific) theme to see if all logos or any other system specific settings are correct/available for systems that I don't really use and/or which are x64 only.
    That particular instance just uses empty dummy files.

  • Global Moderator

    @EctoOne Maybe the problem is with the difference between the 2 systems - on Windows I assume yor're using @jdrassa's daily build, on Pi you might be using the (default) Emulationstation package. They're built from different branches of the RetroPie's Emulationstation repository (master vs stable). Unless you're using on the Pi also the master branch through the emulationstation-dev package.

  • @mitu Nope, I'm using the dev build on my Pi as well. And the other two setups on my PC, which worked, used the same build. I assume it has something to do with my es_systems.cfg and/or the way I've set up the dummy files. Maybe I see if I can rework the setup but like I said, I currently don't care.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.