Please do not post a support request without first reading and following the advice in

PSX emulation not working

  • I'm setting up an old PC to run retropie for an arcade cabinet all other emulators that I've tried work fine, but lr-beetle-psx refuses to load. I have even tried pcsx-rearmed, yes, I know it's meant for ARM, and that hangs at a black screen. I have the proper bios file renamed to what the emulator is looking for.
    The PC is Intel Core2Duo E6550, 2 GB RAM, and nVidia Geforce 7600-GT. Does it have anything to do with the legacy NVIDIA 304.137 driver I had to install?

  • Global Moderator

    Without a log file it's hard to know if it's just the BIOS, the emulator or you have a bad ROM.
    Please add the info asked in, including a the /dev/shm/runcommand.log log file taken after the emulator fails.

  • I also forgot to mention Debian 9 Stretch LXDE
    here is the runcommand log

    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-beetle-psx/ --config /opt/retropie/configs/psx/retroarch.cfg "/home/dale/RetroPie/roms/psx/Crash Bandicoot (USA).cue" --appendconfig /dev/shm/retroarch.cfg
    unhandled setting UI: psx.input.port1.gun_chairs
    unhandled setting UI: psx.input.port2.gun_chairs
    unhandled setting UI: psx.input.port3.gun_chairs
    unhandled setting UI: psx.input.port4.gun_chairs
    unhandled setting UI: psx.input.port5.gun_chairs
    unhandled setting UI: psx.input.port6.gun_chairs
    unhandled setting UI: psx.input.port7.gun_chairs
    unhandled setting UI: psx.input.port8.gun_chairs

  • Global Moderator

    @gokuh306 Can you enable verbose logging, then get the log file again and upload it to ? What BIOS files do you have present ?

  • @gokuh306 said in PSX emulation not working:

    Intel Core2Duo E6550

    I recommend overclocking if possible, you won't get great performances on psx with a computer @ 2.33Ghz, that's definitely not enough for lr-beetle-psx, and that's probably barely enough for lr-pcsx-rearmed.

  • It seems like the multiplier is locked. I think I was able to track down a reasonably priced 3.1 ghz core 2 to replace it with. Once I upgrade the graphics card in my main PC, I'll probably put the geforce 570 in there, too.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.