Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[SOLVED] Menu inputs showing onscreen as text before launching game



  • Hi,

    Using Retropie 4.3 on a Raspberry Pi 3b+. Carbon theme. GPU overclock but not CPU. 64Gb SD card, with a MegaPi case and shutdown script.

    I've got things pretty much how I want them! Really pleased with my set up but some slight snagging to do before I settle. Firstly I'm noticing that on occasion I am getting what looks like the inputs I'm making as I navigate the menus, showing onscreen before I launch a title. It's very odd and I'm not sure what I would do to stop it as it seems to occur randomly. Looks a bit like the below text (may not be entirely syntax-accurate), depending on how many ups and downs etc. that I've pressed before I launch a game:

    [[A ] [[A] [[E] [[A] [   ] [   ]
    

    Can be longer or shorter depending on the inputs made beforehand as I say, but you get the idea.

    I do have one or two items set to suppress boot text but i don't think this is related. Anyone have any idea what can be done? Many thanks.


  • Global Moderator

    @Ranma If they're text artifacts, they can be from the output of RetroPie-Setup, Runcommand or other text scripts. Most likely from a runcommand where you pressed some keys or buttons that are not mapped and produce some keycodes. I wouldn't worry about it.



  • Thanks for replying. :-)

    Yes they are text artefacts. By the looks of it they are from very much mapped inputs, and appear to be the inputs I make in the menu itself (up, down etc) before I launch any given game like I say. While I agree it's nothing to worry about (everything is running soooo well!), I'd really like to hide/get rid of them.



  • You could try disabling joystick input in run command, if its detecting the inputs after you have selected to launch a game. You could also try using a launching image for run command that might help hide the text.



  • @jakejm79 said in Menu inputs showing onscreen as text before launching game:

    You could try disabling joystick input in run command, if its detecting the inputs after you have selected to launch a game. You could also try using a launching image for run command that might help hide the text.

    Tried this, but the issue is that it's showing the inputs I am making in the menu before I select a game, not any inputs I'm randomly hammering as the game loads. So it's showing all the times I've hit up, down, left, right etc in the menu before I click on a game. I'm already using launching images btw.

    Thanks though.



  • Maybe if you made the launching image (unless you are just using the box art, screenshot, etc) to be the size of the resolution used to display ES it would hide things.



  • I seem to have fixed this. I found a page (here) with a few extra instructions on suppressing various messages. I haven't implemented them all but it seems the one or two I have added have done the trick! I'd already added one or two of these as per the excellent Retropie docs, but the extra bits here seem to have done the trick. Been mashing about the menu for a couple of hours, and rebooted several times and so far it has not returned.

    Thanks for your help. Thrilled to get it working so nice! :-)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.