Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Skyscraper won't work



  • So I recently downloaded skyscraper on my raspberry Pi 3B+ through the Retropie Setup menu and tried to run it using the terminal. That failed and said the file was missing. I made sure to check if everything was installed and tried again but it failed.
    If anybody has installed Skyscraper before through the Retropie Setup menu, please help walk me through on how to use Skyscraper (without having to type a bunch of stuff).

    Thanks and please ask any questions.

    Pi Model: 3B+
    Power Supply used: 5V
    RetroPie Version Used: 4.4.4
    Built From: Pre made (Build from Retropie Website
    USB Devices connected: Keyboard
    Controller used: Xbox One (wireless)
    Error messages received:
    Guide used: "Skyscraper now officially part of RetroPie, please test"


  • Global Moderator



  • @mitu
    So I have tried using the terminal in basic mode but it always comes up with the error:
    running script... /home/pi/.skyscraper.skyscript.sh: 2: /home/pi/.skyscraper/skyscript.sh: Skyscraper: not found
    So I answer all the questions required and it fails.
    I've tried going into the Configurations/Tools tab and Skyscraper appears, but it appears with the message: "Skyscraper cannot be run while EmulationStation is running or it will overwrite data. Please run Skyscraper from the terminal."
    ^ So I have run it from the terminal but it fails, and ES won't let me run it from the Script...

    I'm lost still...


  • Global Moderator

    @LemonAid After you exit Emulationstation, run

    sudo ./RetroPie-Setup/retropie_setup.sh
    

    and then follow the docs. Skyscraper is under Configuration/Tools.



  • @mitu
    Well I tried running sudo ./RetroPie-Setup/retropie_setup.shand I tried to scrape using all of the websites but it kept showing data not found. I tried every single website and it kept saying data not found. Nothing was scraped even after I tried twice.

    I still don't understand whats wrong. It keeps failing no matter what.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.