Please do not post a support request without first reading and following the advice in

  • Pi Model 3B
    RetroPie Version Used 4.4.4
    Controller used: ps2 controller/dragonrise arcade stick/keyboard

    A newbie to retropie I have had my pi up and running no issues with my ps2 controllers and keyboard. I had configured the ps2 controllers in Emulation station and all worked ok.

    A first try at using another controller was trying out my 360 wireless controllers with MS dongle. Emulationstation could see the xbox controllers and they worked in menu until launching a game. Once I launched a game the xbox controller would just not be there anymore. When I exited out using Retroarch the Xbox controller was not responsive in emulationstation anymore. On reboot it didn't save the xbox controller and it would need re-configured each boot.

    I wasn't thinking of sticking with the Xbox controller so I bought a Dragonrise arcade stick instead. Plugged in this acted the same as the xbox controller. It works when configured with the menu but isn' t available in game. Like the xbox controller it is gone once I exit from the game.

    When I configure the Dragonrise controller in Emulationstation and then quit and reboot the configuration isn't saved when Emulationstation boots up.

    I've tried the using SDL as the driver and tried updating Emulationstation and Retropie but seem to have created more issues for myself. Now I can't get any controller to save details in Emulationstation. Even my ps2 controllers that worked fine to begin with are borked when I exit out of a game. Essentially when I exit a game back to Emulationstation the controllers are all unresponisive until rebooted and re-configured.

    I've search for forum related answers but could only find stuff about controller not working due to multiple controllers being used. ie 2 dragonrise controllers. I've tried configuring my controllers all in isolation but still same. Any pointers/help much appreciated. I'm used to using PC's but haven't used another OS than Windows up to now. I have network access to my pi from PC and only barebones command line knowledge.

  • Global Moderator

    @BulletApe Looks like a bad SDcard, if your configuration is not saved - or maybe a permissions issue. If you use 1 controller at a time, do you still get these problems ?
    Are you using a proper power supply ?

  • Bad SD card doesnt make sense as I was getting the same issues from the Xbox controller pre buying the dragonrise one. While getting the Xbox issues I could still use and save the PS2 controller configs.

    I did however do the reset permissions thingy in the retropie setup recently. Didn't help for me. The Sdcard is new and although quite loaded has a decent amount of GB's free. I don't know how to check the sdcard properly.

    I tried one controller at a time earlier and just had same experience. Controllers configure fine in Emulationstation but are lost on a game launch. The ps2 controllers still work in game but all controllers seem to disappear on return to Emulationstation post game.

    The power supply is a 2.5amp. Bought the pi already loaded from Ebay.

  • Global Moderator

    @BulletApe said in Emulationstation not saving controllers:

    Bought the pi already loaded from Ebay.

    And this might be your problem. We don't support 3rd party images - especially ones sold with a PI system. The RetroPie license prohibits commercial usage, so people selling RetroPie kits (with ROMs or not) are just scammers.
    Use the image from for any support from the forums.

  • OK. Apologies for posting I wasn't aware of this. I'll look for help elsewhere.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.