Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Hori RAP4 buttons work in MAME 2003, but not joystick



  • @markwkidd Games I tested so far button 1 and 2 work.
    @Mebejedi Button 2 you mean default second button or are you trying to map a specific button/key ?



  • @UDb23 !, I'll try to explain my button mapping. (I really hate how these things are labelled.....very confusing)

    Based on this picture from https://docs.libretro.com/library/mame2003_plus/
    alt text

    I swapped my buttons so that menu choices/game select/fire are all the same button. My buttons are mapped this way:
    alt text

    I can get Guns to work in Aerofighters....but nothing I map Bombs to works. (Just to clarify, this is in MAME 2003, not Plus, but it was working before I installed Plus.)



  • Tried some other games. In 2003, Button 2 doesn't work in Aero Fighters (World USA + Canada/Korea/Hong Kong) or Armor Attack
    However, it DOES work in Elevator Action Returns (Ver 2.20 1995/02/20) I even tried switching Button 1 with Button 2, but it doesn't matter.

    I'm not sure which MAME version these ROMs are yet. I haven't tried CLampro(sp)? yet. I have downloaded MAME_2003-Plus_Reference_Set_2018. I'll try some more games.

    In 2003 Plus, all buttons work, but no joystick.

    [EDIT] Tried it with keyboard. X key works in 2003, but not Z



  • @Mebejedi unlikely it is related to romset. Does this specific joystick don’t work or any joystick?
    Current version of m2003plus has an issue so l can’t enter the RGUI menu. As soon as fixed will check about the button remapping.



  • @UDb23 , I just wanted to be thorough. I have a couple of different hand controllers. I'll try them.

    Ok, this is the first time I've plugged in a second controller (bought a pack of various controllers for my son's computer, but also intended to use them for this.) I'm trying it in FBA first, because I know this section works.

    Problem is, when I load a game (1941), the Hori starts controlling the 2nd player (and works perfectly). However, my Hotkey no longer works (have to press escape on keyboard to exit). Back in the menu, the Hori works as expected. How do I keep the Hori as 1st player, and X Box controller as second?

    Once I figure out how to do this, I'll try it in MAME.

    Also, if the X Box were my main controller, which key should be the Hotkey? I use Key 13 on the back of my Hori because it's out of the way. Can't imagine which key I'd sacrifice on the X Box controller.

    [EDIT] Looks like people are using the Select key on the X Box controller.



  • @UDb23 , went ahead and unplugged Hori, swapped with X Box (which came up as USB joystick.)

    Dpad didn't work, but tried it with Analog stick and it worked. When I hit the Analog/Digital switch, the Dpad worked. Nice touch being able to switch controls on the fly like that.

    I removed the X Box and replaced the Hori. Still no joy on the Joystick, so it might be controller-specific.

    BTW, I somehow turned off the config menu (for emulators, etc) that comes up before the game. I had turned off warnings

    Ok...did some more messing around. I turned on the MAME menu (dip switches, etc....BTW, how do I turn this off in-game?)

    MAME Menu
    Analog on - joystick moves cursor
    Digital on - Dpad, joystick moves cursor

    Retroarch Menu
    Analog on - Dpad moves cursor
    Digital on - Neither Dpad nor joystick moves cursor



  • @Mebejedi have already tested the hori joystick with jtest ? More info here.



  • @Mebejedi Order of gamepads should follow the order you plugged them in. Used to be related to usb port previously.



  • @UDb23 I get this error

    pi@Pi_Derek:~ $ jstest /dev/input/js0
    bash: jstest: command not found

    That said, I know my joystick works, because it works in 2003, FBA, Atari 2600, etc...

    [EDIT] Just installed Joystick. Joystick and all buttons work.



  • for mame2003-plus on digital only turn analog off you only turn this on for analog controllers if your using them.

    ie snes and joysticks use dpads (digital hat). analog off( this is the default mode)

    you should do the following in settings
    enable legacy mapping ( this is important when it needed for analog or games using analog controls even on a dpad)

    in analog mode : directons are on axis 0 an axis 1 (lstick)

    in analog mode off (dpad is used)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.