Please do not post a support request without first reading and following the advice in

Joystick buttons not detected properly in SNES only

  • @mitu I only have SNES at the moment. Can you suggest another system to install and try? As I developed this virtual input device, I could debug the device in many ways before asking in this forum. I mentioned jstest and evtest because these are the tools everyone knows.

  • Global Moderator

    @lproj Well, the NES is a simpler system - so you could try that. But as far as RetroArch is concerned, it should be the same thing - buttons. Can you re-do your button mapping in RetroArch and create a re-map for the core ? This way you can check if RA registers your buttons when mapping them.

  • Global Moderator

    One idea that comes to mind - switch the input_driver in the .cfg file from udev to sdl2 and see if it makes a difference in-game.

  • @mitu I switched the input_driver as you said, but nothing changed. I uninstalled RetroPie from the menu and installed the packages again, but now NO buttons are detected at all from within the game (ES still works fine).

    I am going to restart from scratch from a fresh rpi installation.

  • I reinstalled everything from scratch but still no luck. Not all the buttons work in the game, while they are ok in ES. :( Do you have any other ideas?

  • Global Moderator

    How exactly is your joystick built ? You didn't give any details about it - did you wire it to the GPIO, is it a custom USB connector, keyboard etc. ?

  • It's a pure software-based udev/uinput device emulating the same buttons/axes as my real USB Dragon something Joystick. From the point of view of the events that it generates and that can be observed by e.g. jstest, this virtual device is no different from the real Joystick. These buttons/axes are controlled by the software based on some real events coming from another host in the LAN which is a PC with a USB Joystick plugged in. I am trying to entirely play games from within a browser where Retropie runs on an headless Rpi (with no display, no speakers, no keyboard, no real controller). But this probably another story, there is another post mentioning this.

  • Global Moderator

    Seems similar to, which was followed by, but without any real solution.
    Since you're only using SNES right now, I assume you're using a Libretro core (lr-snes2010 maybe). Have you tried re-mapping the buttons in the RGUI (like I mentioned a few posts above) through in the Input menu ?
    I guess a RetroArch log file (launch the game with verbose logging from the Runcommand launch menu, then get paste the contents of /dev/shm/runcommand.log on wouldn't hurt, but I'm not sure what would we be looking at.

  • @mitu As soon as I enter Retroarch GUI, the same problem occurs: I can only scroll up and down the menu, and press one button, but unfortunately the button required to enter the submenu to do the remapping is not detected.

    This is the log:

    EDIT: I forgot to mention that I had also tried "nes" before reinstalling everything and I got the same problem.

  • I found the problem (or just one solution atm). There is something that libretro does not like in the driver implementation. Now I can fully play the Super Mario in the PC browser and on Android Chrome in my smartphone.

    Sorry for the noise and thanks for your time, but hopefully everyone will benefit from this once I have made a demo.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.