Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

USB controller problems



  • Pi Model or other hardware: Raspberry Pi 3 (RPi3) Model B Quad-Core 1.2 GHz 1 GB RAM
    Power Supply used: 2.5A (the power supply came with this kit: https://www.amazon.com/gp/product/B01C6Q2GSY/ref=oh_aui_search_asin_title?ie=UTF8&psc=1)
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): retropie-4.4-rpi2_rpi3.img
    Built From: (Pre made SD Image on RetroPie website, Berryboot, or on top of existing OS etc.. - please provide the filename of any image used): NOOBS_v3_0_0
    USB Devices connected: USB thumb drive for ROM's
    Controller used: Keyboard, mouse, two Buffalo SNES controllers, one Atari 2600 joystick controller (all USB)
    Error messages received: The only error I see when Raspbian is booting up is the following:

    [FAILED] Failed to start usbmount@dev-sda.service.
    See 'systemctl status usbmount@dev-sda.service' for details

    Log found in /dev/shm/runcommand.log (if relevant):
    Guide used: https://retropie.org.uk/docs/First-Installation/
    File: (File with issue - with FULL path)
    Emulator: (Name of emulator - if applicable)
    Attachment of config files: (PLEASE USE PASTEBIN.COM FOR LARGE LOGS)
    How to replicate the problem: The controllers just don't work any more. They did at one point but don't any longer. The keyboard responds to some commands (arrow left, right, etc.) but the other configured buttons don't. The SNES controllers do not work at all. There is no automatic configuration of the controllers and manual configuration does not work either. If I hold a button down on an SNES controller on startup to get into config mode it does not respond.

    I have reflashed the drive and started fresh with the latest and greatest software. Same problems. I also tried a brand new SD card. Same problems. Unless all of my controllers are bad the only other direction I can point the finger of blame is the motherboard.

    I'm at a loss. Any ideas?


  • Global Moderator

    @TheSausageKing Are your controllers detected by the system ? Run - from the command line - :

    lsusb
    

    Do yo see your controllers listed there, among the USB devices connected to the Pi ?



  • @TheSausageKing do you have another power supply you can try? Canakit power supplies are well known to causes power issues.

    Not saying that is your issue but weird behavior seems to occur when a pi doesn't get enough power.



  • did you do a basic install in the retro pie setup



  • @aatheronb Yes. Standard install.



  • @quicksilver I do not. Are they standard? Should I just be able to purchase any other 2.5A power supply for the Raspberry Pi and expect it to work?


  • administrators

    @quicksilver

    Canakit power supplies are well known to causes power issues.

    I've never had a problem with mine.



  • @mitu I can't even get to a command line. Every time I boot up I get the message that says there are no input devices detected. I start the process of setting up the keyboard as an input device but it just gets stuck on the configuration after I run through the process.



  • @herb_fargus I have seen them be a problem for a lot of people. Others seem to have no issues with them. I had one that came with my first pi kit and under full load I would get the lightning bolt symbol. Running CPUburn a53 is a good way to test cooling/sufficient voltage because it pushes the CPU hard. My canakit power supply always failed on that test. Maybe their quality control isn't the best.

    Edit: I should add that after researching the OP's issue a little bit I doubt the power supply is the cause but I still stand by my assessment that the canakit power supplies aren't the best choice.



  • @TheSausageKing after you map the keyboard are you pressing the button you mapped as "a" to ok the configuration? Once you do it, it can take 20 secs or so sometimes for the configuration to take effect.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.