Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Start, Select, and Hotkey buttons no longer work on my F710 controller after upgrade from RetroPie 4.3 to 4.4



  • I upgrades my version of RetroPie from 4.3 to 4.4 using the included script. Everything is working fine, except my Start, Select, and Hotkey buttons no longer work in any emulator. The start button works in the emulation station menu.

    I deleted the files /opt/retropie/configs/all/retroarch-joypads/Logitech\ Gamepad\ F710.cfg and /home/pi/.emulationstation/es_input.cfg, restarted the Pi, and set up the controller throught the GUI interface.

    The problem persists. The file /opt/retropie/configs/all/retroarch-joypads/Logitech\ Gamepad\ F710.cfg has not been recreated, I am not sure if that is an issue. I tried opening RetroArch from the Retropie Menu, but I can't navigate it with my controller, although I can use a keyboard to do so.

    Pi Model or other hardware: 3B
    RetroPie Version Used : 4.4
    USB Devices connected: 2 F710 controllers
    Controller used: Logitech F710
    Emulator: All


  • administrators

    You will break auto configuration deleting es_input.cfg. did you read somewhere to do this?

    You should reset it from Retropie-setup / configuration / emulationstation


  • administrators

    Not that your older RetroPie was based on Jessie which is no longer supported. You should start from a fresh 4.4 image.



  • @Rincewind Get back the default file here



  • @BuZz Yes I did see it in a guide, I can't remember where. I am not enthused by the idea of setting up a fresh image again, but if I don't come right, then I will.

    @cyperghost The buttons work in the games now, but not on the retroarch menu.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.