Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Help with interference and hissing problem on speakers and amplifier for Bartop project



  • Hi Everybody,

    I'm in the process of putting together a Retropie Bartop arcade build and am experiencing excessive amounts of hissing and interference from the amplifier and speakers I'm using:

    https://www.arcadeworlduk.com/products/hi-fi-stereo-sound-amplifier-kit-for-arcade-machine-projects.html

    To clarify I experience an exceptional amount of hiss and interference:

    • When the pi is running and there is no sound
    • When the amp and speakers are turned on and disconnected from the Pi

    To date I have tried the following to try to resolve this issue:

    • Added better quality speaker wire between the amp and speakers
    • Tried using a better quality RCA lead between the PI and amp
    • Tried connecting the PI to the amp via the amps mp3 input
    • Added a ground loop noise isolator between the PI and the amp
    • Adjusted the Rasperry Pi 3.5 audio config to remove noise

    I'm pretty sure the problem is the amp/speakers and not the PI.

    I've had a look through a lot of threads on here and have been unable to find a solution for my problem.

    Could somebody recommend a better amp and speakers which doesn't suffer from this problem?

    The setup needs to use 3.5mm audio jack (not usb) and the speakers need to be flat fronted and 4" sqaure to fit a bitcade 19" bartop speaker bar:

    423290a6-0bc1-40aa-bb8b-28b59cde2833-image.png ![alt text](image url)

    I've had a long look around the internet and can only really seem to see cheap amps and speakers which look to be just as bad.

    Any advice or recommendations would be really appreciated.



  • @rogerdodger how are you hooking up the audio? If from a raspberry pi’s analog out, that port is very noisy and doesn’t give out clean audio. You can either take the feed from the hdmi or get a cheap usb audio device that will be much better.



  • @lostless From the analog port.

    The mointor I'm using doesn't have hdmi so I'm using a hdmi to vga converter and running audio from the analog port.

    If I go the usb audio route:

    • What sort of amp/soundcard is worth using (I would like a separate external volume control)
    • What compatible speakers could be mounted on the cab's speaker bar.

    Thanks





  • @rogerdodger I had this problem. The amplifier that you show actually amplified my issue as I had a similar one and sent it back. I decided to build an amplifier. Same issue. After a bit of searching, I came across this resource. What worked for me was a combination of adding disable_audio_dither=1 to /boot/config.txt and not having the volume set too high in the retropie setup, say around 60%. I then hacked apart a set of old speakers that had reasonable quality electronics inside and used that to amplify the sound. I ended up tweaking the volume setting in Retropie whilst experimenting with the volume control on the speakers and managed to get virtually no hiss. I think that the HDMI to 3.5" converter is a good idea too but I have not tried it.







  • Thanks very much for all the useful help and suggestions.

    I'll let you know how I get on.



  • @rogerdodger Welcome to Retropieforum :-) and welcome to the world of RPi audio annoyances :-/

    For USB-Audio Devices with 3.5mm jack almost any (c-media compatible) will work.
    Any I did test had a better S/N than the on-board 3.5mm jack, e.g.:

    ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter
    ID 040d:340a VIA Technologies, Inc.
    ID 1b3f:2008 Generalplus Technology Inc.
    

    From another project (no Arcade) I know that the HiFiBerry DAC+ standard provides even better sound.

    I had very good experiences (read: precise, noiseless audio) in both projects with Sure Electronics amps.

    You can build a dedicated, external volume knob by using a dual potentiometer (50k Ohm, logarithmic) in between the Rpi out and the amp in.

    Some troubleshooting hints:
    I assume -without knowing the real schematic- the 5v from Pi and the 12v/18v/24v from the amp share the same ground. Have you tried feeding them with two separate supplies - one for the pi and one for the amp?

    Are you using LED stripes in the arcade or nearby to the arcade? They may induce audio noise if they switch a a high rate (impossible to perceive with the human eye - LED stripe makers may use this trick (POV) to save energy and to prolong the LED lifetime).

    If you use LED stripes inside the arcade and drive them via PWM, this may also induce noise. Some possible solutions are sketched here or here.

    Last but not least, double insulating audio wires may have some benefits.

    HTH



  • I've managed to fix the problem.

    As many of you have suggested it is all down to the dreaded 3.5mm audio jack.

    As per the suggestions @Lolonois and @lostless I now hav emy amplifier and speakers connected to the Pi via a usb sound card and everything is blissfully noise free.

    I do still have one minor problem in that I'm getting the error:

    lv10: VolumeControl::init() Failed to find mixer elements

    I wondering if this is part of the reason why sound doesn't work in my splash screen video's when the device boots?


  • Global Moderator

    @rogerdodger said in Help with interference and hissing problem on speakers and amplifier for Bartop project:

    I wondering if this is part of the reason why sound doesn't work in my splash screen video's when the device boots?

    May be - try to make the USB card the default soundcard, either by disabling the onboard sound or changing the order of cards.
    https://retropie.org.uk/docs/Sound-Issues/



  • @mitu Brilliant, looks like all the information I need is in there.

    I'll let you know how I get on.



  • Right I've solved the problem and now have everything working correctly.

    Many thanks for everybody's help with this.

    I thought it might be useful for future reference to close with a summary of the issue and how it was resolved.

    Problem Summary

    3.5mm audio output on Rasperry Pi causing hiss and interference from RetroPie sound output.

    System info

    Rasperry Pi Model: Raspberry Pi 3 Model B+
    Distro: Rasperian 9 (Stretch)
    RetroPie Version: 4.3

    Solution

    Disabling the on board 3.5mm audio jack and using a USB sound card (https://www.amazon.co.uk/gp/product/B07MNRRT84/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1) to connect the amplifier and speakers.

    USB sound card installation steps

    1. Disable the on board 3.5mm audio jack in /boot/config.txt:
      Change the line:

      dtparam=audio=on
      

      to:

      dtparam=audio=off
      
    2. Under Sound Settings within Emulation Station select:

      Audio Device: Speaker
      
      OMX Player Audio Device: Local
      

      Note, you may also wish to turn up the system volume however this is down to personal preference.

    3. Optional step to enable sound in Splash screen videos

      Update the script:

      /opt/retropie/supplementary/splashscreen/asplashscreen.sh
      

      change the line:

      omxplayer -o <option> -b --layer 10000 "$line"
      

      to read:

      omxplayer -o alsa -b --layer 10000 "$line"
      


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.