Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Im getting Bus Error and Emulation Station is crashing



  • I just bought a Raspberry Pi Zero W and keep getting this Bus Error. Despite many reimages including updating the files in Retropie. It crashes to this every time or outright freezes or crashes EmulationStation. I have already tried a different and known working Micro SD card. Along with a different power supply.

    Im thinking perhaps I have a failty Raspberry Pi Zero W. But if anyone has other ideas I can try them too.

    7E1CB0D8-96C9-4A78-9587-8F94933A2AF4.jpeg


  • Global Moderator

    @Seohn Are you sure you're using the right image - the image specifically for the Pi 0/1 ?



  • @mitu Unless the official website has it listed wrong. Yes Im using the right image. I selected and downloaded the one pacifically for Pi Zero. Even downloaded it again a second time thinking maybe it was a bad download.


  • Global Moderator

    @Seohn can you try re-installing from source the Emulationstation package ? If that doesn't work, try the manual installation method,on top of the Raspbian lite image.



  • @mitu I tried uninstalling Emulationstation then reinstalling both from source and tried from binary. Same issue occures.

    As for Raspi Lite. Ive not tried installing just it. But to be fair I’ve never installed Raspbian directly. I’ve only ever used the images in the short time its been since I started using a Raspberry Pi.

    My Raspberry Pi 3B+ had no issues at all getting up and running. So was a bit suprised to have issues with the Zero. But having built computers for years. I shouldve expected to run into an issue at least once.

    I already have a new Pi Zero on the way and it wont be until tomorrow until I get a chance to work on it again. I’m going to try it first after work. And then look into installing each thing one by one instead of using the Ready made Pi Zero image I have from here if it the same problem occures.



  • @mitu So when I got home I took the microSD card that was in the raspberry pi zero W that I think is faulty. And just moved it over to the new raspberry pie zero w that arrived in the mail today. And it seems to be working a lot better. It booted up just fine to EmulationStation and I’m not getting any of the button issues that I was having when I had it in the Retroflag GPi case. It occasionally gave input configuration crashes too.

    I tested only one Atari game on it and it seems to be working (where as before I could never keep it from crashing long enough to run a game). However I’ve only started transferring games over and havent tested any others. Either way it’s not freezing like it was just a few seconds after loading up emulation station. And it has yet to crash. Which means so far that’s a really good sign.

    When I’m done transferring the files over, doing a scrape for the game images, and can actually spend some time playing games on it. I’ll be glad and certain of what the issue was. But based on all the trouble I was having and I’m using the exact same microSD card with everything that was installed before. So far I’m convined that I had a faulty raspberry pi zero W.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.