Please do not post a support request without first reading and following the advice in

GPI Case XRoar emulator crashes. (Solved)

  • Hello

    I am using the GPI Case with Retropie imaged to the sd card. Emulators such as GB, GBC, GBA, NES, SNES are working find with no issue.
    I wanted to try and get some CoCo games running, however when I set it up the emulator will just quit without showing anything.
    In the runcommand log file it shows the emulator is getting a (random number) segment fault error. I've tried using different BIOS files, different cartridge images, and I tried coco and cocous.
    In the emulators config I changed the "-vo sdl" to -vo sdlgl and it will still quit the same way, however the runcommand log will show:

    Executing: /opt/retropie/emulators/xroar/bin/xroar -fs -vo sdlgl --ccr simple -machine cocous -run "/home/pi/RetroPie/roms/coco/Canyon Climber (1982) (26-3089) [!].ccc"
    ERROR: No video module initialised.
    Module init: SDL2 UI
    Module init: No file requester
    Module shutdown: No file requester

    Is this an issue with SDL and Emulation Station not liking one another?
    If so is there a way to get it this to work?


    Pi Model or other hardware: P0 and P0W
    Power Supply used: USB power cable and aa batteries
    RetroPie Version Used: 4.4/retropie-4.4-rpi1_zero.img.gz
    I also tried updating:

    Merge: a48a82d8 9974d8dc
    Author: Jools Wills <>
    Date:   Sun Jun 9 05:57:11 2019 +0100
        Merge pull request #2732 from cmitu/psx-chd-support
        psx: really add CHD as extension

    Built From: Pre-made Image on RetroPie website: The Raspberry Pi 0/1 from
    USB Devices connected: GPI Case:
    Controller used: GPI Case
    Error messages received: None.
    Log found in /dev/shm/runcommand.log:

    Executing: /opt/retropie/emulators/xroar/bin/xroar -fs -vo sdl --ccr simple -machine coco -run "/home/pi/RetroPie/roms/coco/Downland.ccc"
    /opt/retropie/supplementary/runcommand/ line 1012:  1235 Segmentation fault      /opt/retropie/emulators/xroar/bin/xroar -fs -vo sdl --ccr simple -machine coco -run "/home/pi/RetroPie/roms/coco/Downland.ccc"

    Guide used: and
    Emulator: XRoar
    Attachment of config files: Using default config.
    How to replicate the problem: Burn Retropie image to SD card, install XRoar emulator, put bas13.rom file in BIOS folder, put .ccc rom in coco folder.

  • I installed installed a fresh copy of Retropie and installed XRoar without updating Retropie's update scripts. This installed Xroar version 0.33.2, this version runs.

    I then updated Retropie's update script and installed XRoar, it now installs version 0.35.4, this version crashes.

  • Global Moderator

    @K9Kraken What's your resolution ? Maybe the new version doesn't like the resolution you have.

  • Here is where I am at:
    -Version 0.33.2: DPAD does not work and so far I cannot get it to map, the buttons I can map.
    -Version 0.35.4: Crashes.
    -Also need to figure out a way to exit the emulator instead of rebooting the system.

    I've installed XRoar 0.35.4 on my desktop linux machine. It runs and I'm able to map the gamepad axis from the analog stick to the DPAD. (xroar -joy joy0 -joy-axis X=6 -joy-axis Y=7 --machine cocous -run Downland.ccc)

    Going to test installing 0.33.2 on my desktop machine to see if it has the mapping issue, I will also try installing some of the between versions on my raspberry to test. (I installed 0.33.2 on my desktop linux and mapping the axis to dpad is still working.)

    I also sent Ciaran Anscomb the XRoar programmer an email about this issue:

  • Global Moderator

    @K9Kraken I think that newer versions use SDL2 instead of SDL1, it might be worth keeping the SDL1 version around until SDL2 gets more stable.

  • @mitu

    Yes thanks, after testing a few of the versions the issue starts when SDL2 was implemented. If I remove "-vo sdl" and add "-ui null" the emulator will run but of course has no display.

    I did try different resolutions with default settings with the same results.

  • Global Moderator

    @K9Kraken You still didn't mention what's the resolution on the GPI case - maybe SDL2 can 'learn' about it.

  • @mitu The screen resolution is 320x240. I tried selecting that resolution but still crashing.

  • Global Moderator

    @K9Kraken Try adding dispmanx as the video driver - edit /opt/retropie/configs/all/dispmanx.cfg (create the file if it doesn't exist) and add


    Try re-running again with the latest xroar version and see if it gets something displayed.

  • Thanks for the input, I contacted the developer and by adding the parameter "--disable-kbd-translate" to ./configure in the build script I was able to compile and run the latest version.

    Now will need to work on these issues:
    -New version is running slow.
    -Cannot map in DPAD.
    -Way to exit emulator without having to reboot the system.


  • Global Moderator

    @K9Kraken said in GPI Case XRoar emulator crashes. (Solved):

    -Way to exit emulator without having to reboot the system.

    I wonder if this is because of --disable-kbd-translate. Do you have a game to compare how slow the new version (compared to the previous one) runs ?

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.