Please do not post a support request without first reading and following the advice in

Hatari and Retropie, problems configuring it with F12 (SOLVED)

  • Global Moderator

    To install packages (including new emulators) see the Docs. I think lr-hatari is in the experimental section of the packages.

  • Great

    I was able to install lr-hatari from the package manager. I previously removed hatari and all related config in order to guarantee start from scratch.

    Now my problem is that if I select an atari st disk from emustation, the white modal screen to launch the emulator is displayed but then black screen and returns again to emustation

    I launched the config from the white modal screen and I can select default emulator, video options etc, but no one configuration related to atari

    I also checked the run command.log file but no errors seem to be displayed.

    Am I doing something wrong?

  • Global Moderator

    @fumanxu Doesn't Hatari need some BIOS files to work ? Are you sure your ROMs are ok ?

  • @mitu no, hatari didn't needed tos since it uses emutos. In any case I replicated hatari.cfg (as commented before pointing to other tos images) and it works

    Regarding the roms, in principle the st files are ok, they are the same used with hatari previously... And they were executed (without controller support) with the previous hatari

  • Global Moderator

    @fumanxu Ok, add more info about your system (see and also post the log file of the emulator - /dev/shm/runcommand.log.

  • Ok, Thank you again for all this valuable support.

    Pi Model or other hardware:Pi Zero W

    Power Supply used: GPI case batteries

    RetroPie Version Used : 4.4

    Built From: Pre made SD Image on RetroPie website

    USB Devices connected: no

    Controller used: gpi case controller built in

    Error messages received:
    In principle, no error messages received.

    Log found in /dev/shm/runcommand.log (if relevant):
    Executing: LD_LIBRARY_PATH='/opt/retropie/libretrocores/lr-hatari' /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-hatari/ --conf$
    [libretro-test]: Got size: 640 x 480.
    Retro SYSTEM_DIRECTORY /home/pi/RetroPie/BIOS
    Retro SAVE_DIRECTORY /home/pi/RetroPie/roms/atarist/
    Retro CONTENT_DIRECTORY /home/pi/.config/retroarch/downloads
    Retro DeInit

    Guide used: (Mention if you followed a guide)
    I installed lr-hatari from package manager as commented in previous posts of this thread.

    File: (File with issue - with FULL path)
    Not applicable

    Emulator: (Name of emulator - if applicable)

    Attachment of config files: (PLEASE USE PASTEBIN.COM FOR LARGE LOGS)
    Not sure which file is needed... there are a lot in retropie.

    How to replicate the problem:

    • Install lr-hatari
    • Copied st files to /home/pi/RetroPie/roms/atarist, in principle they are working since they were tested with hatari (no libreto emulator). The problem with hatari is that the controller is not recognised and I can't access to setup via F12 to configure it in GPI Case.
    • emustation recognizes the st files as ATARI and when I select one of the files the modal white screen to configure the atari emulator launcher is displayed.
    • I push button to configure and lr-hatari is selected as default emulator.
    • If I launch emulator, black screen and returned to emustation.

  • Global Moderator

    @fumanxu said in Hatari and Retropie, problems configuring it with F12:

    Retro CONTENT_DIRECTORY /home/pi/.config/retroarch/downloads

    This is changed from the default - did you use 'Save Configuration' in RetroArch or used 'Save Configuration on Exit' ? What's the name of the ROM you're trying to run ?

  • Global Moderator

    You actually need the BIOS files - at least tos.img to use lr-hatari, so make sure you have the file.

  • Yes, that was the real problem. Since there is not any error, I didn't see which was the proble,

    I read at that : "To use this core you need a valid TOS ROM image named 'tos.img' in your RetroArch system directory."

    So I put it in the system folder that /dev/shm/runcommand.log says :
    Retro SYSTEM_DIRECTORY /home/pi/RetroPie/BIOS

    Now It is working, with controller support and even virtual keyboard displayed when click on Y button.

    I have another problem with the performance, but I think it should be placed in another thread.

    Thanks a lot for the support.

  • I saw this thread, so I set up lr-hatari, got it working, and updated the docs, mostly just from the core's github readme. It worked pretty much first try, but the docs previously only covered Hatari standalone.

    One thing I am not clear on is how you get the core to look at different BIOS files in order to emulate the STE or Falcon, but I haven't tried that yet.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.