Please do not post a support request without first reading and following the advice in

Help resetting PI that got stuck configuring joystick

  • Hello friends,

    I'm a rookie here so I appreciate any quick tips.
    I'm setting up a Raspberry Pi 3 with Retropie 4.5
    -CanaKit 2.5A Power suppply
    -Built from a SD with an image from the RetroPie website
    -USB Devices connected: Mac keyboard, generic mouse
    -Controller used: Retrolink Atari joystick
    -Guide used:

    I tried configuring the joystick, but the available keys on the joystick ran out. And now I can't get out of the configure gamepad screen.
    I tried press+holding any key on both the keyboard and joystick
    I tried press+holding F4
    I can't ssh into the board

    Is there a way left to reset the board?

    Please advise,

  • @Razak

    You should be able to hold down a key on each of the remaining joystick configuration options and then exit, so it sounds like it has crashed to me.

    Have you done any other setup, or did you only get as far as setting up the joystick?

    If you haven't done anything else, then you could just copy your roms (assuming you have put some on there) off the SD card and then reflash the image and start again.

  • If Retropie isn't responding at all, you could try the Magic SysRq keys. You'll need a keyboard that has a key with "SysRq" on it ("S-Abf" on German keyboards). On most PC keyboards it's Alt+PrtSc. While holding SysRq or whatever key combination it's on your keyboard, you'll have to press these keys one after another: R, E, I, S, U, B ("Raising Elefants Is So Utterly Boring" 😉 )

    This will free the keyboard (R), ask all processes except the low-level "init" to stop (E), kill them if they won't (I), write all ram-buffered data to the disk (S), remount all partitions read-only (U), and finally reboot the system (B).

    Depending on your Linux system, only SUB will work for security reasons, but its enough for this purpose. I don't know how Retropie is configured ex-factory in this regard.

    TL;DR: Magic SysRq + REISUB will save all buffered data from a frozen Retropie and reboot it as safely as possible in this state. If it doesn't respond even to that, you may as well kill its power.

  • Hi Clyde,

    Thanks very much. If I'm on a Mac keyboard with no SysReq key what would the alternative be?

    Did I just paint myself in a corner?

    Is there a safe way to pull out the power on a PI? I've already fried one board before.

  • @Razak Don't you know any PC owners who can lend you a USB keyboard with an SysRq key? That would be the easiest solution.

    Alas, as far as a quick web search went, there's no way to enter SysRq commands with a Mac keyboard without shell access, which you don't have. (And if you had, you could just enter sudo poweroff or sudo reboot in the shell.)

    Normally, just unplugging the Pi's power shouldn't make any trouble as long as you take general precautions like never pulling a plug at its cable. That said, I would advise you to pull the plug on the wall's side rather than the Pi's side, but that may be just superstition. The greater risk than frying your Pi is to lose data that hasn't been saved, or corrupting your sd card if you cut the power at the same time as the Pi is writing to the sd card.

    edit: Oh, and if your Pi has no insulated case, you should ground yourself before touching its board.

  • Another idea: Like most Linux systems, Retropie has so-called virtual consoles that you may access by pressing Ctrl, Alt and one of the F-Keys (e.g. Ctrl+Alt+F2). If that works, you could log into the system and run one of the commands I mentioned above.

  • Global Moderator

    @Razak said in Help resetting PI that got stuck configuring joystick:

    I tried press+holding F4

    F4 should be enough to quit Emulationstation, maybe you need to press Command to activate the key on the Apple keyboard (i.e. Cmd + F4) ?

  • Unplugging the power and trying with a PC keyboard worked. Now F4 works like a charm. I guess the tricky part of getting a ROM in there starts now. Thanks all for the help.

  • @Razak I was just about to suggest you do that it happened to me but on my other topics of homemade ones I didn’t do. But it happened to me on my joystick

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.