Please do not post a support request without first reading and following the advice in

Retropie amiberry image sound and control issues

  • My Apologies. Just to clarify its not an image from a random website it was actually a copy of an image from someone I know, it was made sometime ago so it required updating which I've done

    He has told me it was an official image download from the main page and he built it from that

    I've already asked him but hes not been using the software for a long time and doesn't know what the issue is

    I hope this is acceptable ?

  • Global Moderator

    @trippy86 said in Retropie amiberry image sound and control issues:

    I hope this is acceptable ?

    Not really, since we can't know what configurations or customizations have been made to the image. Starting with a new image would make it easier to diagnose the eventual issues you may encounter as @buzz said.

  • @mitu fair enough I understand, unfortunately I've already put a lot of time and extra customizations into this existing Image so I cant bare to start from scratch.

    Thanks for the replies anyway


  • Just incase anyone has this same problem I resolved it by changing the audio to force HDMI. Can be done via retropie - emulationstation in raspi-config or edit /boot/config.txt

  • One last thing, do wireless mice work on amiberry in retropie as I cant get them to work.......tried both a cheap one and my logitech m515


  • It shouldn't matter if they are wired or wireless. The issue you have to deal with is more likely that the WHLoad setups you are using are configured for controller use and not for keyboard/mouse use.

  • @Thorr69 even on mouse based games? I've tried a number of games that a purely point and click games which require a mouse. Can see the mouse pointer but no movement

  • @trippy86 Try moving your joystick and see if the mouse pointer moves. If it does then it's set to use the controller instead of the mouse.

  • @Thorr69 no movement on that either. If I go into amiberry settings it shows mouse as port 0 and joystick as port 1

  • Some mouse-only games are still setup to use just controllers and not the attached mouse/keyboard when you use the WHDLoad version. Populous, for example. I don't know what i need to do to unset that, so I can't make any suggestion for you on this either (if it's the case).

    My only other suggestion would be to disconnect your controllers before firing up an amiga game and/or switch USB ports so that your mouse and keyboard are on the lower port numbers (0 and 1).

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.