Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SNES controller with duplicated button IDs



  • Hey, all,

    RPI ZERO (not W) with attached SNES 9pin (5 actual) controller to the GPIOs

    The controller was detected and everything works fine EXCEPT:

    X,Y,LShoulder and RShoulder are duplicating A and B button. When i try to assign them i always get ALREADY TAKEN.
    It recognises them as Button-1 and Button-3. So in general i have 3times Button-1 and 3 times Button-2. To me it looks like hardware problem, meaning sh*ty china-made controllers, but i hope i am wrong.

    Any ideas? The problem is that i have tried this with 2 different controllers - same problem.
    It is good to know that both were part of chineese fake game, so could it be that they were just designed to be like NES pads but in the shelf of SNES? Or anything else?


  • Global Moderator

    Use jstest to determine if the button input values are the same for multiple buttons. It could be the controller or the wiring to the GPIO.
    See here how to run jstest.



  • @mitu i tried to reconfigure the controller. For example when i assign physical A button to a specific function, i see the value is 1....then i reset everything and do the same with physycal button X...and again it get same value. I will check the jtest later today.

    The GPIOS i think are correct. No logic in this not to be correct...only 5 wires and rest of the pad is operating normally.

    will run jtest and give feedback later :)



  • After JsTest, when i press the buttons, as i said the corresponding number is blinking ON
    A,X,RShoulder = 1
    B,Y,LShoulder = 3

    Any ideas else then s*tty controllers?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.