Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

How-to guide: Recording Live Gameplay in RetroPie’s RetroArch Emulators Natively on the Raspberry Pi (and Twitch streaming)



  • @meleu excellent idea - I'd actually wondered about doing something like that, but bash scripting isn't really my forte - thanks, I'll update the guide (and give credit where it's due, of course!) when I have time



  • @meleu No time like the present; I've updated the 'Naming the Recording File' boxout with the following:

    UPDATE: RetroPie forum member meleu suggested an improvement to avoid the inconvenience of renaming the file before each emulator launch, by automatically appending the filename with a timestamp (year-month-day-hourminutesecond), for example:
    recording_VCS_2016-07-14-221955.mkv
    This is achieved by updating the --record parameter as follows:
    --record /media/pi/EXT_HDD/RPi_AVI/recording_VCS_$(date +%Y-%m-%d-%H%M%S).mkv

    Thanks again for this excellent suggestion



  • Anyone else having issues getting this done?
    I've recompiled FFMpeg along with the extra codecs, even downloaded and ran the script in the same site.
    RetroArch compiles fine, even though FFMPeg is present, and the --disable-ffmpeg part is removed,
    I still don't have the Recording option (Done this 3-4 times now)



  • @LSolrac2 hi,
    Which version of RetroPie do you have installed? - I'm wondering if something has changed in the 4.x betas, as I used 3.6, 3.7 and 3.8 when creating and testing this process.

    [Edit] just to clarify, when you say 'there is no recording option', is this referring to the entry in the Retroarch GUI menu, rather than the RetroPie runcommand menu?



  • @LSolrac2 have you tested ffmpeg by transcoding some video files from the command line, to ensure it has correctly built and installed?
    Has ffmpeg been installed to the default location so that it can be found by other applications (can you type ffmpeg from anywhere / directory at the terminal)?



  • @LSolrac2 it's worth asking, although I'm sure you'll have followed the process in order, but has Retroarch been recompiled after ffmpeg has been built and installed?
    [Edit] re-reading your post, it seems that you did install ffmpeg before recompiling retroarch, so this question is moot.



  • @meleu said in How-to guide: Recording Live Gameplay in RetroPie’s RetroArch Emulators Natively on the Raspberry Pi (and Twitch streaming):

    @RetroResolution
    YOU
    ARE
    AMAZING!!
    It's a pitty that I can't upvote your post twice or more. :-)

    Upvoted one more on your behalf. :P



  • @senkun cheers!



  • @LSolrac2 hi, some further questions (there are so many parts involved in a RetroPie system...)

    Is your installation from Raspbian image, with RetroPie installed on top, or from a RetroPie image?

    If you used a RetroPie image, do you have the lxde / Raspbian desktop?

    In either case, which version of Raspbian Linux is installed (Wheezy or Jessie)?

    Which version of Retroarch is installed on your system? This is shown at the bottom of the window when the Retroarch GUI menu is being accessed? My version is 1.3.4 on RetroPie 3.8. I notice in retropie's github that the retroarch framework was updated on 17th June, just after I last ran through the installation process . at a glance i can't tell from the source if anything has changed that could be causing the issue.



  • I'm currently undertaking a complete from-scratch install on my Pi 3 using all the latest versions of everything:

    • Raspbian Jessie 27/5/2016 image
    • Manually installed RetroPie 4 rc 1
    • Manually compiled FFmpeg, using the 'all-in-one' script from my FFmpeg compilation guide
    • No overclocking applied

    Part way through the ffmpeg compilation at the moment, having installed RetroPie.

    I have noticed that RetroArch is now version 1.3.6, released June 17th 2016 (my 3.8 RetroPie installation has 1.3.4, which was the released in May 2016), although there's nothing in the release notes to suggest a problem with ffmpeg recording.

    I've checked RetroPie's RetroArch setup script, and this seems to be as it was previously, including the original --disable-ffmpeg parameter.

    I'l post an update later...



  • @RetroResolution
    1a- Something messed up in my 3.8 install, so I updated to 4, so yes, I am running v4
    1b - Nope there's no Recording option, FFmpeg is the recording driver though (instead of null)

    2a -Converted Opus>mp4 perfectly, and currently converting mkv>mp4 (quite slow)
    2b - Any terminal, even ssh can summon almighty ffmpeg

    3a - Yes, in fact, the 3rd time I redid the whole thing, I used your ffmpeg-install.sh script, then the sed -i, removing the --disable-ffmpeg part of retroarch.sh, and then reinstalled from source, using retropie_setup.sh
    3b - Whoops xD I was astonished by the quick reply so I'm replying all of 'em

    4a - As stated previously, it's a retropie image, v4-rc1 to be exact (still hyped for 4, but I think this should be incorporated into the final release cause it's pure awesome)
    4b - I haven't installed it yet cause I wanted to have everything set before, besides I barely use the desktop, might use later when I make a portable case, but for now, I believe I won't be using it anytime soon
    4c - I believe it's Jessie, I tried installing moonlight, which required me to work with the sources.list file, there, it says Jessie

    Seeing your newest post, I hope these details can help your investigation c:



  • @LSolrac2 Hi,

    Thanks for the information, sorry for the deluge of questions.
    I've just completed my installation from scratch (as described in my last post) - luckily the recording feature does still work!

    It seems that in the 1.3.6 release of RetroArch the 'Recording' menu has been removed (I can't find any reference to this in the release notes or elsewhere), however it was pretty superfluous as nothing you change in there has any effect.

    As you've noted above, the entry for 'driver' does now say 'ffmpeg', which is what really counts.

    I just created a recording to the local sd card whilst playing Pitfall II in the VCS emulator, at all appears okay.

    I'm going to undertake more checks and tests, then, assuming things are okay, I'll update the guide on my site!

    [edit] I've just successfully recorded to external hard disk whilst running the PlayStation emulator, at 60fps - so everything looks fine.

    Given the slew of changes recently I'm very glad to see it's working, to be honest...

    [edit] btw the files created can't be played back correctly by omxplayer on the Pi, as the video is using planar 4:4:4; it's simple enough to transcode them to a compatible format (which also works for YouTube and Twitter) - there are examples on the FFmpeg compilation guide for doing this. (this is true also if you use Kodi Media Center). Without transcoding the vide is a complete migraine-inducing mess...



  • @RetroResolution
    Can't wait >u< Hope everything goes smoothly!



  • @LSolrac2 thanks!
    It looks like everything's fine (I edited a couple of my earlier posts, above).

    Apart from the (ineffective) 'Recording' menu no longer being present in RetroArch 1.3.6, the recording is working well - I recorded direct to the SD Card from the VCS emulator, and to a usb hard drive using the PlayStation emulator at 60fps.

    I'm updating the "Recording Live Gameplay" guide at the moment.



  • @RetroResolution

    Okay, all seems well and I've updated the guide to reflect the RetroArch GUI changes in version 1.3.6, and also to show that I've successfully tested the process on RetroPie 3.7, 3.8.1, and version 4 rc-1 (on the latest image of Jessie available, from 27/5/2016)

    Recording Live Gameplay in RetroPie’s RetroArch Emulators Natively on the Raspberry Pi

    Recording with RetroArch 1.3.6



  • I completely forgot to mention; the --record option ended up crashing altogether.



  • @LSolrac2 can you post your emulators.cfg for whichever emulator you're trying to record from?

    If you're using a custom config.cfg to control the ffmpeg recording format, can you post this?

    Also, can you double-check the paths and that there are no case-sensitivity issues in directory or file names?

    Have you checked in /tmp/ for any runcommand.log file? - this often reveals the cause of recording problems



  • @RetroResolution

    Nice! Now I can stream to Twitch sometime soon!



  • @RetroPieNerd that's still an aspect I haven't got sorted, but I do return to it on occasion - perhaps under retroarch 1.3.6 it'll start working (I suspect, though, that it's simply going to be a grind to determine the correct combination of config.cfg settings)



  • @RetroResolution
    Sure thing: http://pastebin.com/k8xg99Fr
    No Config.cfg as I haven't gotten there, yet.
    and the runcommand.log is literally blank.

    cat /tmp/runcommand.log that is



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.