Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Wi-Fi connection issues



  • Raspberry Pie 3b
    Retropie: 4.5.9
    Rasbian: 9.11
    64gb micro sd

    Hello. I was trying to connect to the Wi-Fi to update everything, and somehow lost the ability to. I go to the Wi-Fi section and it says IP Address (unknown). I select the Wi-Fi network option and it says "no wlan0 interface detected." I hooked up an Ethernet cable and it connected to the internet to do my updates. After the updates and a reboot, I still could not get it to connect to the Wi-Fi, for the same reasons above. Does anyone know, in simple terms, how to fix this Please? I do have a keyboard and monitor for the Pie. Thanks!


  • Global Moderator

    Try exiting EmulationStation, then from the command line run:

    sudo rfkill unblock all
    

    Reboot and see if can set-up the WiFi connection.



  • Hi. I tried it. What was I supposed to see happen after I entered the command? It just gave me another command line, like I typed it in incorrectly. I rebooted anyway, and it didn't work.


  • Global Moderator

    @tretti said in Wi-Fi connection issues:

    What was I supposed to see happen after I entered the command?

    According to your error message (no wlan0 interface detected), it looks like you either don't have a Wifi adapter on-board or is disabled.rfkill is an utility to block/unblock the Wifi adapter (just like some laptops have a dedicated Wifi switch).
    Normally you shouldn't have any output after running the command. If you'd like to see the status of the Wifi adapter(s) just run sudo rfkill list allfrom the command line and post the output here.



  • Sorry, that doesn't give me any info either. Just another command line. I type it in exactly how u have it, right? From sudo and include all of the spaces?



  • @mitu Sorry, that doesn't give me any info either. Just another command line. I type it in exactly how u have it, right? From sudo and include all of the spaces? Should my Ethernet be plugged in?


  • Global Moderator

    @tretti said in Wi-Fi connection issues:

    I type it in exactly how u have it, right? From sudo and include all of the spaces?

    Yes, just like it's shown.

    Sorry, that doesn't give me any info either.

    Are you sure your Pi has Wifi ? Did you accidentally disabled it by editing the config.txt file ?



  • @mitu yes, I double checked the board I have and it has Wi-Fi. The only file I edited was the Skyscraper user name and password section. How and where do I look to see if the config .txt file is worded properly for the WiFi?


  • Global Moderator

    @tretti Just post the file's contents here, surrounded by code fences (```).



  • @mitu

    # For more options and information see
    # http://rpf.io/configtxt
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256
    overscan_scale=1
    

  • Global Moderator

    Doesn't seem to be any conflict in the config.txt; I can't understand why your Wifi is not detected.
    Can you run dmesg and post the output to pastebin.com so we can take a look ? You can run from the command line

    dmesg > $HOME/RetroPie/roms/dmesg_out.txt
    

    then check the roms folder and copy the lines from the dmesg_out.txt file for sending it to pastebin.com. You can then delete the .txt file.



  • @mitu Ok, I am having trouble figuring this one out. I typed in what you typed in a command line, a couple different ways, and it didn't get me anywhere. I'm going to try sending picture to show you. And the IP Address that is showing is because of my Ethernet being plugged in.20200109_042938.jpg


  • Global Moderator

    @tretti The 2nd command was correct - the output of dmesg is stored in the dmesg_out.txt file, which you can open from your PC by accessing \\retropie\roms. Get the file's contents and post it on pastebin.com, then provide the link.



  • @mitu Ok, that really helped! Thank you. I sent it on over and labeled it "tretti dmesg.txt"


  • Global Moderator

    @tretti Can you provide the link to it, here in the topic ?



  • @mitu Sorry, never used the site before.

    https://pastebin.com/7Rz0fD6D


  • Global Moderator

    There's no error regarding the wifi in the log - are you sure you're entering the wifi name and password correctly in the Wifi connection dialog ? Did you try setting the language/country from raspi-config (as explained in the linked page) ?



  • @mitu I can't even get that far to enter that info. Tells me wlan0 network not found. I tried to set the country then, and it gave me the same message.



  • @mitu What is the likelihood that the wifi/Bluetooth module went bad?


  • Global Moderator

    @tretti said in Wi-Fi connection issues:

    What is the likelihood that the wifi/Bluetooth module went bad?

    Did it ever worked ? It's quite unlikely to break without any physical damage done to the Pi (i.e. soldering or shorting something on the board).



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.