Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Unable to find Pi 3 for windows file explorer



  • Hello first I want to say I’m basically a noob so keep it as basic as possible but I thought someone here might be able to help, here’s my situation. So I gave up on my pi 3 a couple years ago after I updating to retropie 4.3.8(can’t remember what version I had prior). After doing so my Pi no longer is found by my PC to transfer roms nor found by WinSCP. So far I have verified my Pi and PC are on the same network and have tried typing in both ‘\retropie’ and the Pi’s IP address into file explorer and web browsers. I tried enabling SSH on the Pi and turned off firewall on the PC and still nothing.

    If anyone is willing to help I’d be thrilled, it’s been too long feeling like there’s no answer to this, let me know what other info I can provide because I’m sure I’m leaving stuff out , thanks in advance!



  • You aren't typing in the right thing. You want \RETROPIE. If that doesn't work then use a USB stick.



  • @IceChes1 said in Unable to find Pi 3 for windows file explorer:

    You aren't typing in the right thing. You want \RETROPIE. If that doesn't work then use a USB stick.

    Yeah, and you didn't either.

    \\retropie
    or
    \\ip.ad.re.ss



  • @Thorr69 unfortunately none of these have worked



  • @MDtar7 enable samba. It's the only thing you haven't mentioned and it doesn't work without SMB shares.

    It's set under Retropie setup, configuration, samba shares I believe.
    You might also have to change your network location on the computer to private as well, but try samba first.



  • @Parabolaralus so I just tried that and it ran code and installed what it needed for a few minutes for samba and it also enabled it but still no luck. Then I made sure I was set to public network and still nothing :/



  • A couple of things to watch for with this:

    1. make sure both the computer and the Pi are using the same type of connection to your router. Many routers have built-in isolation between Wired and WiFi. SO if both are wired or both are wifi, they should see each other, but is one is wired and the other is wifi, then they will have difficulty. (My router has a setting for wireless isolation and I still can't get them to see each other if they are not both on the wired connection. Both wired, no problem.)
    2. I've found the Pi can get stuck with the wrong IP address internally. Sometimes I have to remove all devices from my router and force everything to re-acquire IP addresses. For instance, my Pi fires up and gets 192.1.68.1.3. Then I turn it off for a couple of days and when I come back, 1.3 is occupied by another device. But the Pi still keeps trying to use 1.3 even though it should have received a new Ip address. It causes lots of headaches. I run a pie 3b, so I found the only way to fix this was to keep everything wired and not use wifi on it.

    Those may or may not help, but they are what I have run into when dealing with this very problem. (I have the same problems with my OrangePi, too. I use a usb ethernet adapter on that one to solve it.)



  • @MDtar7 said in Unable to find Pi 3 for windows file explorer:

    Then I made sure I was set to public network and still nothing :/

    You would want Private network, not Public. Public would hide all the devices from each other. Private is a trusted network and thus all the devices become visible to each other.



  • @Thorr69 sorry I meant private



  • I type \\RETROPIE

    I guess you would have tried this
    my 2cents



  • Oops. Did I do one backslash? I meant two. Sorry for the typo.



  • @IceChes1 Lets narrow down this issue. What is the IP address of your computer and your Pi?
    You can find it by opening a command prompt on the computer and type in ipconfig hit enter.
    On the Pi exit emulationstation and its listed right up top.



  • @Parabolaralus Pi 192.168.0.123
    PC 192.168.0.31



  • @MDtar7 Have you checked if your PC can reach Pi's IP ?
    From windows command prompt, use ping command:
    PING 192.168.0.123



  • @UDb23 yes I did ping the Pi’s IP and it worked



  • If none of the above works, restart your PC, disconnect from the internet and use a wired connection.



  • @MDtar7 Im running out of ideas, but try enabling SMB 1.0 support on your PC.
    Its in Control Panel, Programs and Features, Turn Windows Feature On or Off and select SMB 1.0/CIFS File Sharing Support. Restart your computer and try it again.
    Screenshot from 2020-03-26 12-21-15.png



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.