Please do not post a support request without first reading and following the advice in

  • Hi All,

    I'm really hoping that someone is able to help me with this as I have spent countless hours trying to get this working.
    I have a Raspberry Pi 3B+ running Retropie 4.6.2 with a Mayflash Dolphinbar to use with a Wii controller as a Lightgun.

    This works well for lr-mame2003 for games like Operation wolf, Alien3, Terminator2 etc. I've got it working in lr-pcsx-rearmed for Time Crisis. I've also just set up in lr-fceumm as a proof of concept to get it working with Duck Hunt and Hogan's Alley.

    I really want to get this working for House of the Dead 2 on Dreamcast and some other Naomi games.

    The steps I have followed are below

    • Run HOTD2 in lr-flycast (dreamcast version)

    • Enter retroarch quick menu > options > show light gun settings > On

    • Save Game Options File

    • Go back to Settings > Input > Port 1 Binds

    • Set device type to Light Gun and bind the gun buttons to the buttons on my wiimote. Mouse index is set to 0

    • Save Configuration and restart ROM

    • Go back into the quick menu > options > set light gun crosshairs

    • After several restarts and checking that settings persist, it's still not working

    I've tried this several times over and even rebuilt my retropie image from scratch. I've used different ROMs to make sure that wasn't the issue.

    The dolphinbar is plugged into port 0 on the pi (which is the only port it works in for MAME etc)
    I have tested by running cat /dev/input/mouse0 and moving the wii controller around, which gives me an output.
    I've checked the logs at /dev/shm/runcommand.log and confirmed that the mouse is bound to 0. I've tried every other binding just in case.

    [INFO] [udev]: Mouse #0 (/dev/input/event1).
    [INFO] [udev]: Mouse #1 (/dev/input/js0).
    [INFO] [udev]: Mouse #2 (/dev/input/mouse0).
    [INFO] [udev]: Plugged pad: DragonRise Inc. Generic USB Joystick (121:6)$
    [INFO] [udev]: Pad #0 (/dev/input/event4) supports 0 force feedback effects.
    [INFO] [udev]: Plugged pad: DragonRise Inc. Generic USB Joystick (121:6)$
    [INFO] [udev]: Pad #1 (/dev/input/event3) supports 0 force feedback effects.
    [INFO] [Joypad]: Found joypad driver: "udev".
    [WARN] [udev]: Full-screen pointer won't be available.
    [INFO] [Video]: Found display server: null

    If I hold the coin/select button on the arcade stick, it then shows a cursor in the midlle of the screen which to me says it's not taking the mouse coordinates input.

    I've also tested with other Naomi roms but still having the same issue

    I know that there have been several people that have been able to get this to work so hopefully someone can help


  • @Buzzle not sure if you've seen this on Reddit:

    I've not attempted this yet, still setting up my RPI4 but will be giving it a go probably next week.

    Let me know if you have any luck...

  • @Buzzle I ran into the exact same issue, every time the game restarted the bindings failed to stick. All the other settings remained though.

    The only way I could fix it was to configure the controller each time, which lead to frustration so I sidelined it. If someone has a workaround I would love to know as well.

    I should point out I followed the guide that @andykt76 linked

  • ah yes, finally tried it. Got it working on House of the Dead 2 for Naomi. Can't get settings to stick on reboot. If anyone has solved this please chime in.

  • @andykt76 Same as me I can't get the setting to stick after reboot either.

  • OK I've sussed it out! Settings also saving when relaunching Retroarch (Flycast) - Only tested on House of the Dead 2 so far, will be trying out mappings for the other games when I get time.

    Here's a step by step process of what I did, some of it may not be needed, but it's the process I followed to get it working...

    Stuff needed: Mayflash dolphin-bar, Wiimote (already paired to the bar), another controller (in my case a 8bitdo SN30 Pro) already mapped in Emulation Station. A keyboard.

    Right, let's get started:

    • Boot up your image of Emulation Station
    • Whilst it's booting up, make sure your Mayflash dolphin-bar is set to 1 (everywhere else seems to suggest 2, but 1 works for me)
    • Make sure wiimote led 1 and 2 are lit up (press home and down until they are)
    • On your 8bitdo, press start
    • Click on Configure Controllers
    • Press and hold a button on the wiimote (the screen will show "Keyboard")
    • Map your D-pad on your Wiimote to the up,down,left and right
    • Start - map to button 1
    • Select - map to button 2
    • Button A - map to the home button
    • skip the other mappings by holding down on the d-pad until you get to hotkey
    • Map hotkey to button 2 (same as what you mapped select to, so you can easily quit retroarch by pressing 1 and 2 on the wiimote)
    • Now to Options in Emulation Station
    • Scroll to Emulation>Retroarch and start it
    • using your gamepad, move right one, then down to Input>set menu toggle gamepad combo. Change this to start+select on your 8bitdo
    • Go to input>port 1 binds
    • Scroll down to lightgun
    • Click on Gun trigger and press wiimote trigger
    • Click on gun aux A, click on wiimote "A" button
    • Click on gun start, on wiimote click 1 button
    • Click on gun select, on wiimote click 2 button
    • Then map D-pad controls on wiimote to up/down/left/right
    • Scroll up and click Save Autoconfig
    • Come out of that menu and go left, scroll down to Configuration file
    • Click Save Current Configuration
    • Save it!
    • Exit retroarch
    • In EmulationStation load House of the Dead 2
    • When game starts, enter quick menu (select and start on 8bitdo)
    • Scroll down to controls
    • Go to port 1 controls
    • Change device type to lightgun
    • Click "save game remap file"
    • Exit Retroarch
    • Restart House of the Dead 2
    • Press button 2 on your wiimote to add coins
    • Press button 1 to start
    • Kill Zombies!

  • @andykt76 Thanks, I'd given up trying to get this working. I'll try out tonight. Hopefully it works with Noami and Atomiswave games as well.

  • @Krakatoa found that my target reciticule was sticking when firing, so tried remapping the controls again with the dolphin bar in mode 2. Works much better and the controls survive a reboot, so think I've nailed it. Now to get two guns working at the same time...

  • @andykt76 Well I tried and now this time I can't get retropie to register the A button or the trigger on the wii mote. At first I thought it was because I had a keyboard plugged in but it wasn't that. So I'm going to give up again, its just not worth the hassle.

    Got it working, thanks for the help.

  • @Krakatoa If you are interested, I got other systems working too

    PS1 games:

    SSH into \home\RetroPie-Setup\scriptmodules\libretrocores\


    Open it with Notepad ++

    Change the section to be like this:
    function sources_lr-pcsx-rearmed() {gitPullOrClone "$md_build"}

    Now go into EmulationStation, or SSH into your box (sudo /home/pi/RetroPie-Setup/
    Go into Options>RPSETUP
    Manage packages>Manage main packages>lr-pcsx-rearmed>Remove
    Then do an update from source.
    Now when you launch PS1 games, go into Quick Menu, then in Options select Pad 1 Type = guncon

    When that has finished then you load lr-pcsx-rearmed as your emulator as usual. Then on the menu under options you can change Pad 1 Type to "guncon".

    Tested on Elemental Gearbolt, Time Crisis I and II and it works well. However, some games are not working, Die Hard/Die Hard 2, Lethal Enforcers I and II.

    For NES,
    got into Retroarch Quick Menu
    Change Port 1 binds device type to "Zapper"
    Map Wiimote buttons same as on Dreamcast example
    In Quick Menu, enable "lightgun settings"
    then go to Options and change Zapper Mode to "Touchscreen"
    save configs and restart

    For SNES, similar to NES, but when launching a game, when the splashscreen for NES comes up, press the button on your controller to bring up the launch menu
    Change the emulator for the rom to "lr-SNES9x"
    When Retroarch loads, go to main menu inputs
    Go to Port 2 Binds
    Select SuperScope
    Map trigger, alt fire like before
    In Quick Menu, check lightgun mode "touchscreen"

    Master System, same as NES
    Port 1 - MS Light Phasrer
    In Quick menu turn on show cross hair
    touchscreen mode
    save game mappings

    Set port 2 binds to "MD Menacer"
    Same settings elsewhere (i.e. touchscreen)

    Still not bad progress!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.