Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Pi Model or other hardware: Pi4
    Power Supply used: Official 3 pin Uk Plug
    RetroPie Version Used: 4.6
    Built From: RetroPie website image
    Core/Emulator: lr-mupen64plus-next & mupen64-GLideN64 & gles2rice

    Hi all, I'm just wondering if anyone has seen this before and if I'm missing an easy fix that exists for DK64. So I have a video the issue here:-

    Do excuse the gorilla style recording, but what appears to be happening is the camera keeps resetting itself back a half second or two every second.

    But the game only does this while the camera is moveable by the player (when the camera icon appears in the top corner to show the camera is fixed in place, the issue disappears).

    What's strange is I've tested this on my pi3b+ with the older mupen64-auto emulator and the game runs fine. So it suggests either I'm missing a setting or the bug is recent.

    Anyway, can some lovely people here have a test and see if they can duplicate this bug please? I tried the USA and PAL versions of the game, it appears in both of them for me.


  • @retropieuser555 I noticed the same issue, and as you noted it works fine with older mupen64plus on the pi 3. I was unable to find a solution for it unfortunately. I believe I saw the bug reported somewhere on GitHub but im unable to find it.


  • I have the same bug.

    I notice that it even does it in the demo video, but it does not when it shows the next demo video (the on in tunnels with rails). So, does it stops after the first area of the game?

    Have you guys found a solution since then?

    Thx!


  • @Nakynaw no solution yet. It doesn't happen when the camera is in fixed angles. Like outside of cranky's house or in a tunnel. But I think the glitch exists all the way through the game (although I'm not about to test that)

    It's frustrating as the game used to run fine on older mupen64plus versions, somewhere a fix for one problem has brought about this glitch imo.


  • I was having this issue using GLideN64 on RaspPi 4, i was able to fix it by turning off "framebufferEmulation\copyDepthtoRDRam = 0" in the GLideN64.custom.ini file.

    /opt/retropie/configs/n64/GLideN64.custom.ini

    [DONKEY%20KONG%2064]
    Good_Name=Donkey Kong 64 (E)(J)(U)
    frameBufferEmulation\copyDepthToRDRAM= 0

    now DK runs smoothly


  • @RuttleHead Perfect that has fixed it for for me! Thanks man!

    Edit: Out of curiosity, does anyone know which settings in the lr core we'd need to edit to make this change as well? As I was messing turning the frameBufferEmulation = True and copyDepth = off but it doesn't seem to fix the issue in the lr-mupen64plus-next core. Any ideas?


  • Did some more digging on this problem, I didn't realise when lr-mupen64plus-next is built the GLideN64.custom.ini file is used. Learn something new everyday. Anyway I tested it by building from source, editing the tmp folder of the build to make your change, then rebuilt from source. Voila the game's camera is totally fixed in the lr-mupen64plus-next core.

    I've sent an issue under github and made a pull request for my edit. So hopefully they'll update it.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.