Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

EmulationStation Not Recognizing Wii Classic Controller Pros (SOLVED)



  • @BlackRiot which adapter did you get? Raphnet has a good one in both chip only and cable. I had a mayflash one and the bumpers didnt work. The wii u wireless one states that the bumpers dont work. Not sure why they dont work on wither adapter??? The wiimote style at least on older setups the direction pad and d pad didnt work at the same time. If you have the left analog set on its default setting in whatever wii file it was, in n64 it worked as analog. If you swapped the analog and d pad settings the dpad worked as dpad not analog in n64 makes no sense??? I was hoping they fixed the problems so i thought i would nbe able to use wiimotes on a pi nes mini but couldnt get it to work. So i will stick to using the hard wired classic controller ports only when i get the nes mini and mod it



  • The adapter seems like a good idea. It seems like it takes some work to get that working too, though. Hopefully that guide will be updated... it says that it was updated for version 3.7. Maybe something changed from 3.8 onward?



  • @hylatio the adapter from raphnet-tech.com works great. No problems at all. Configures just like any other usb controller. I would remove and purge the file that the tutorial made you install if you go another route than the wiimote way. One of the problems it had when i did have it work was any wiimotes you set up were forced as your first controllers. Even if they arent turned on. Not sure if its still the same but it doesnt appear they made too many changes.



  • @edmaul69 Thanks for the heads up about the Mayflash adapter and the Raphnet. Good to know that there are options out there.

    @hylatio Hopefully, EmulationStation should recognize the controllers once you plug it in like USB controllers. I'm in no rush to get it now though since I'll be working abroad soon.



  • @BlackRiot yup usb is easy peasy. I wish that the wiimote method wasnt such a pain in the butt. I actually made a mod with a classic controller board inside a project box that allowed me to use atari paddles, modified apple ii joystick, atari joysticks, sega master system controllers, and neo geo controllers. Also i modified controllers with a 9 pin cable removing their circuits, all 4 style nes controllers, turbografx 2 button controllers, (both a pcengine blue and pc engine shuttle controller) fairchild channel f joysticks, an atari flashback 7800 mini joystick and several others i cant think of at the moment. Then i modified some controllers to use a 15 pin pinout like the neo geo uses but using all the pins. I modded a genesis 6 button, a super nintendo controller, a 6 button pc engine controller and a 3 button pc engine controller. Then i have an n64 controller modified as a classic controller with a chip from raphnet. Then i modded an atari joystick and an atari paddle with a nunchuck board inside plus another mod with a nunchuck board that lets me plug in atari paddles and my modded apple iie joystick in.


  • administrators

    Did you try adding a udev rule for the controller from the Bluetooth configuration menu? May help (or not).



  • @BuZz the tutorial has you add a udev rule. Didnt try from inside the bluetooth menu myself.


  • administrators

    Reply was meant for OP, but it may well need more than that. Don't have the classic controller to test.



  • @BuZz yeah i know. Thats why i stated myself. :) I tried this a few days ago to fail miserably even though i had done it many times before 3.7.



  • Long update, but I resolved this issue using the Mayflash Wireless Sensor Bar (https://www.amazon.ca/Mayflash-W010-Wireless-Sensor-DolphinBar/dp/B00HZWEB74/ref=sr_1_3?s=electronics&ie=UTF8&qid=1525130286&sr=1-3&keywords=mayflash+wii), which circumvents the pesky control configurations.

    Thanks, everybody!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.