Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PlayStation 2 / PlatStation 3 / USB joypad? A config file.



  • Hello.

    Recently I acquired a PlayStation 2 / PlayStation 3 joypad with the USB and ability to connect to PC / Rpi.

    As I'm only a regular user and cannot do anything more with the computers, I thought maybe somebody of You guys had the same kind of joypad and maybe You could just send me / upload somewhere Your config file with some short description where should I put the file on the Rpi disk?

    I have Rpi2. I suppose it's, like, RetroPie 2 or 3 Beta?

    I don't actually need the pad, but sadly seems like some of the machines (Nintendo 64? PS-1?) require the analogue joysticks......??

    We have some 'retro-show' this weekend and I wanted to display the Rpi2 with RetroPie and a big monitor. The joypad would be a nice addition but without configuration is kind of useless (and behave strangely, to say at least).



  • Your request makes no sense. Just plug in the controller and power on, EmulationStation will come up with the input config. Do that and now you have all the config files you need.



  • your reply makes no sense.
    if it worked, I'd to it long time ago. it doesn't, so I need someone having the PS3 USB controller and being kind enough to copy one small file for me.


  • Global Moderator

    @yerzmyey you've given essentially no information about the controller you're using. what's a 'PlayStation 2 / PlayStation 3 joypad'? there's a number of different PS2/3 1st/3rd party usb joypads, and they will have separate configurations.

    you will have much more luck actually detailing what is going wrong when you try to configure it



  • @yerzmyey a config file won't make your joysticks be detected by the Raspbian OS.

    If they were detected, the method suggested by @suprjami would make sense for you.

    (I hope my response makes sense.)



  • Those matters are completely strange to me, just saw a video on the YouTube and a dude showing the process. Which is very strange from what I see on my (the same) retropie.
    So I figured out - prolly the controller / pad is broken. The only way to check it out would be to put there a proper file and then I'd know for 100% whether it works or not.

    So yes, it was indeed retropie 2.0.1A. But as long as it works perfectly fine for now, I will not take a risk to change it into another (it took us enough weeks to make work this one, as previously it got dead every single time we added more than several games (files). Like some damn "critical mass" of files.
    This one works great so far and I handle it 'with kid gloves', hahahaha.

    The controller was some kinda simple "Esperanza EG106" but I suspect there are thousands of such 'companies' do don't think anybody would actually know what it is.

    I press CONFIGURE INPUT.

    Then I see HOLD A BUTTON ON YOUR DEVICE TO CONFIGURE IT.
    1 GAMEPAD DETECTED.

    I press & hold a key but when it enters the configuration mode...
    the UP key (the first to set up) - is already taken by something called "AXIS 2 -".
    And I cannot get back to this position with cursor-keys of the PC keyboard.

    Well, anywayz - I try to configure it after all. So I set up all the other keys, hoping that THEN it might return to the UP key and maybe then I could change it. And it returns to the UP key setting up - but I cannot put there anything (not only the actual UP key).

    Also - I cannot leave this configuration mode any more, as the OK button isn't active.

    So I have to press F4 and the hell machine goes out but of course the config isn't saved and it doesn't work in games. So what is "AXIS 2 -" and why it's being 'pressed' - have no idea.

    I cannot break it more, as it already doesn't work. So putting somebody else's file wouldn't hurt too much, I imagine.

    Regards.



  • Hey,
    so - like I thought - with the added data nobody can suggest what the problem could be after all?



  • @yerzmyey
    The only reason axis-2 would show up is that the joysticks are not properly calibrated, a potentiometer is bad, or the controller has a very sensitive dead zone. Retropie thinks an axis is being held. Sounds like a controller that may not work well with Linux in general.



  • OK, that what I was afraid of actually, thanks for Your time.

    So the most reasonably thing is to get several of them and just test which one works. That makes kinda sense.

    Thank You for Your time.


  • Global Moderator

    @yerzmyey please don't delete topics just because you're finished with the issue. this forum serves as a support archive for everyone :)



  • @dankcushions Was rather lookin' for some "solved" button? Really, this forum engine is far too confusing for old people. "Terminated" problem? You know what I mean? Does it even makes sense, hahaha? I liked the old forums' engines.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.