Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Help with PCSX2 on Ubuntu based RetroPie installation.



  • Well, just as the title states. I need help figuring out what has gone wrong. I installed the PCSX2 "experimental package", the ES/ RPI GUI shows that a PS2 emulator/ ROMs are available, I try to run the ROMs, and the emulator crashes and returns to the RetroPie/ ES GUI.

    I believe it to be related to where I have placed the BIOS files, but I have searched the interwebs up and down and cannot find the correct procedure for configuring PCSX2 in a Linux based RetroPie install...

    Help?!



  • Bueller, ? Bueller, ? No one, huh? I'm still not convinced that I have the files dropped off in the correct directory, but I have another issue now. I figured I would try to update the PCSX2 files from the source and instead got this message:

    Log started at: Sun Jan 15 07:19:56 PST 2017

    = = = = = = = = = = = = = = = = = = = = =
    Installing 'pcsx2' : PS2 emulator PCSX2
    = = = = = = = = = = = = = = = = = = = = =

    Reading package lists...
    Building dependency tree...
    Reading state information...
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    pcsx2:i386 : Depends: libportaudio2:i386 (>= 19+svn20101113) but it is not going to be installed
    Recommends: libasound2-plugins:i386 but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    Unable to install binary for pcsx2

    Log ended at: Sun Jan 15 07:19:56 PST 2017
    Total running time: 0 hours, 0 mins, 0 secs

    Anyone?



  • I have solved that by installing libportaudio2:i386 and libportaudio2 using apt-get



  • @KamikadzeM22
    Thank you for the reply. I already worked through it a few hours after I posted this... I tried using apt-get and it wouldn't because "it's out of date- blah blah blah" whatever, but used the "install -f" command to force it to install. The emulator starts and runs, but now I have another issue... My processor doesn't keep up... On to the next issue!



  • @LARoehr Any chance you can explain how you got it running? I'm having a bit of trouble figuring it out on my own as I am pretty new to Linux.

    Thanks.



  • @waxler9311
    You'll have to wait until this evening until I'm off of work for me to try to help you.

    Which part are you having trouble with? Are you running into the same dependency problem? or its just not running?



  • @LARoehr I ran into the same problem but I did end up getting that fixed after some time. Now the issue is I can't get a game to launch. I'm not sure if I need the bios files in a certain location or if the BIOS folder under RetroPie is correct. I did see it is different for the Pi but I can't find any information on this for a Ubuntu install.



  • @LARoehr I was wrong. It showed as installed but once I tried to update to see if that was the problem, it kicked it back out so I guess I never did fix the first problem and thats where I am at. If you can give any advice, let me know. Thanks.



  • I know this threadis old. But I got this working and confirmed on UBUNTU SERVER 16.04 LTS.
    All I did was add the PCSX2 ppa, updated apt and then installed via the retropie setup menu. Easy as pi.



  • @zigzrx Thank you so much bro!!!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.