Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Trouble Setting up the PSX



  • Pi Model or other hardware: Raspberry Pi 3 B
    Power Supply used: 5V 2.5A
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): Used, unsure which version number
    USB Devices connected: keyboard
    Controller used: Buffalo SNES controller
    Error messages received: None
    File: (File with issue - with FULL path) SCPH1001.BIN
    Emulator: PSX

    I am trying to play PS1 games on my Raspberry Pi, but I am unable to get the games I have uploaded to work. I have reviewed some of the tutorials online to get help, but I am unsure what is wrong and I do not have the knowledge to start messing with the files. I am checking with the experts on this forum so I do not do something that might hurt my system.

    Attached are two images. The first is of the "bios" folder where I placed the "SCPH1001.BIN" file. I do not know if the file does not work or if it is not in the correct location.

    0_1487609093904_upload-70e5c273-cb30-40c6-a5ee-2cb3aac3964c

    The second image is of the "roms/psx" folder. I have placed a number of roms in the folder. I originally placed the files for "Metal Gear Solid" (7z file) and "Syphon Filter 2" (RAR file) in this folder and they did not show up on the Retropie. After I placed the CUE files in the folder for both games they showed up in the Retropie, but they would not load so I could play them. Yesterday I placed the "Metal Gear Solid (v1.1)" CUE file in the folder. It showed up in Retropie, but it did not work. I do not know at this point if I have too many files in the folder and if I need to delete some of them. I am waiting to see if the problem is with the "SCPH1001.BIN".

    0_1487609242999_upload-12b802e7-4d86-4189-9f80-0d828963357d

    Any help is appreciated. I thank you in advance.



  • I think that you need the .bin file + .cue file, when you descompress your .rar/.7z files you should get both.



  • @flop I apologize, but I have no experience and no knowledge with this stuff. How do I go about decompressing my .rar/.7z files? I have a CueMaker and that is what I used to create the "Metal Gear Solid (USA) (Disc 1) (v1.1)" cue file from the "Metal Gear Solid (USA) (Disc 1) (v1.1).7z" file. Thank you for your help.


  • administrators

    @redviking42 There is lots of information about unpacking 7z files on the web - you need 7zip. You also need to read the retropie documentation for psx - https://retropie.org.uk/docs/Playstation-1/



  • I have figured it out. I had to download 7z1604 and unecm. I also had cuemakerdotnet previously downloaded. After some time I was able to convert my files to .bin and .cue.

    The Metal Gear Solid .7z files I had to use each of them to finally create the correct files. For Syphon Filter 2 I downloaded new .7z files. When I ran the files through 7z1604 it created .bin and .cue files for me.

    I tested Metal Gear Solid and the game loaded. Played just a the first part and it worked fine, both graphics and audio. Syphon Filter 2 worked perfect too.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.