Please do not post a support request without first reading and following the advice in

  • I am running the RetroPie for Ubuntu (RPi version 4.1.16, Ubuntu version 16.04) on an old HP pavilion p6243w. It initially cam with a very slow Sempron CPU that would run N64 and PSX emulators just barely. If I configured the resolution exactly right, it worked ok. So I figured I'd upgrade the CPU to put an end to the problem and be able to run the Ubuntu OS at the max resolution without slowing down my emulation.

    For $22 I picked up a Phenom X4 9650 that made mupen64 gameplay flawless regardless of the resolution set, but now PCSX just loads a blank screen and hangs until I kill the program.

    I've tried updating ubuntu, all retropie packages, uninstalling/ reinstalling PCSX, and reinstalling Ubuntu and RetroPie all together with no success. The /dev/shm/runcommand.log sheds no light on the issue, as it seems the emulator doesn't even start, so it never logs an error...

    Anyone have any suggestions?

  • I'm not sure if this can help someone else, but it did not help me understand where the problem lies... Here is the runcommand.log file:

    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-pcsx-rearmed/ --config /opt/retropie/configs/psx/retroarch.cfg "/home/retropie/RetroPie/roms/psx/Cool Boarders (USA).cue" --appendconfig /dev/shm/retroarch.cfg
    Starting PCSX-ReARMed
    Running PCSX Version 1.9 (Feb 25 2017).
    Mapped (RAM/scrp/ROM/LUTs/TC):
    found BIOS file: SCPH1001.BIN
    RGB565 supported, using it
    plugin: plugins/builtin_gpu
    plugin: plugins/builtin_spu
    plugin: plugins/builtin_pad
    plugin: plugins/builtin_pad
    Plugins loaded.
    Loaded CD Image: /home/retropie/RetroPie/roms/psx/Cool Boarders (USA).cue[+cue].
    Track 01 (DATA) - Start 00:02:00, Length 02:01:38
    Track 02 (AUDIO) - Start 02:05:38, Length 00:16:51
    Track 03 (AUDIO) - Start 02:24:14, Length 02:36:37
    Track 04 (AUDIO) - Start 05:02:51, Length 02:46:57
    Track 05 (AUDIO) - Start 07:51:33, Length 02:39:01
    Track 06 (AUDIO) - Start 10:32:34, Length 02:44:02
    Track 07 (AUDIO) - Start 13:18:36, Length 03:01:66
    Track 08 (AUDIO) - Start 16:22:27, Length 03:02:02
    Track 09 (AUDIO) - Start 19:26:29, Length 03:15:13
    Track 10 (AUDIO) - Start 22:43:42, Length 02:29:53
    Track 11 (AUDIO) - Start 25:15:20, Length 01:01:53
    Track 12 (AUDIO) - Start 26:18:73, Length 00:08:55
    Track 13 (AUDIO) - Start 26:29:53, Length 01:56:11
    Track 14 (AUDIO) - Start 28:27:64, Length 03:06:60
    selected sound output driver: libretro
    CD-ROM ID: SCUS94356
    CD-ROM EXE Name: SCUS_943.56;1

  • Bueller? Bueller? No one?

    So I have (after many painful hours) determined that the source of the problem comes from the "proprietary" video card drivers for my NVidia display adapter. Unfortunately for me, the Ubuntu GUI doesn't like to run properly with the open source X window drivers.

    So, I guess I'm kinda stuck on this particular machine without

    • a) finding the problem with the proprietary drivers in PCSX
    • b) finding the problem with the open source drivers in Ubuntu
    • c) buying a display adapter that has functioning drivers
    • d) using a different emulator supported by RetroPie/ Retroarch/ PCSX/ etc.
    • e) some other suggestion... ?

  • @LARoehr

    I have been searching everywhere for the reason why my emulationstation crashes when trying to launch pcsx. It was working no problem, and then I installed the drivers for nvidia (this was so I could use the more intense emulators, like Dolphin)

    I came across your post and I think we have similar problems. If you enable the "save on exit" feature and try to launch a game in pcsx, it will still crash, but it will create a save file. Go directly into retroarch under the retropie menu and go to recent. It load the save file. Not very intuiative, but you can check to see if that works for you. Then we know we have similar issues.

    The log files show no issues, but it seems retroarch does not auto load. Or it's loading and freezing the interface. Let me know if you can load off of a save file and we can bounce ideas off each other?

  • Global Moderator

    if you're running x86 you shouldn't be running pcsx rearmed anyway, as it's specifically for ARM systems. you should run lr-beetle instead.

  • @dankcushions
    But it runs great on 3 of my other x86 (x64, actually) systems. Just not on this one with this particular video card driver. If you don't mind my asking, how does lr-beetle measure up to pcsx?

  • Global Moderator

    @LARoehr said in lr-pcsx-rearmed black screen:

    But it runs great on 3 of my other x86 (x64, actually) systems. Just not on this one with this particular video card driver. If you don't mind my asking, how does lr-beetle measure up to pcsx?

    it's just a fairly old emulator that does a good job of running games at native resolution on low-power arm devices, but if you have a powerful PC then beetle is a better choice as it has loads more features (high resolution, perspective correction, etc), and is constantly updated.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.