Please do not post a support request without first reading and following the advice in

Arcade stick works with all emulators except MAME

  • So I'm a budget minded guy. When I find a deal, I try to take advantage. I bought a Mayfair arcade stick last week on Amazon and it came in last night. I plugged it in, went through the EmulationStation configuration, can navigate menus like a champ. I can play SNES, NES, Genesis, FinalBurn Alpha, PSX, etc. For the life of me, I can't get MAME to recognize my inputs from the joystick itself.

    I did note that during ES setup I saw the directions on the joystick being identified as HAT0+, HAT0-, HAT1+, and HAT1-. Is it possible that

    1. MAME won't use what is being sent as hat switch controls
    2. I can "trick" MAME into reading the hat inputs as joy0
    3. I should ship the Mayfair stick back and buy a different one

    Pi Model or other hardware: Pi 3b with Samsung 32 GB EVO SD card (MB-ME32DA/AM)
    Power Supply used: Canakit DCAR-052A5 2.5 A
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.1
    Built From: Pre made SD Image on RetroPie website, retropie-4.1-rpi2_rpi3
    USB Devices connected: Keyboard, arcade stick
    Controller used: Arcade stick
    Error messages received: No message
    Log found in /dev/shm/runcommand.log (if relevant): I'm not sure how to retrieve this.
    Guide used: Installation guide from
    File: I don't know if this applies
    Emulator: MAME4ALL
    Attachment of config files: Again, unsure how to retrieve
    How to replicate the problem: Attempt to configure controls in MAME

  • administrators

    @tygr20 standalone mame4all? Any reason not to use lr-mame2003? It should work better.

  • @BuZz is this as simple as changing the emulator on a rom in the start up config screen? The "Press a key to config" screen? I've installed multiple MAME emulators in RP after finding I needed to change the version being used on specific ROMs.

  • administrators

    @tygr20 You will need a matching romset - and you may need to put them in another location.

    Please have a look at

  • @BuZz Thanks. I'll give this a shot as soon as I get home this evening.

  • @BuZz well, I tried MAME 2003. Still no luck. When I push the stick in any direction, MAME isn't registering the input. Still works everywhere except MAME.

  • Scratch that- it IS working. Turns out when I changed the default emulator it wasn't saving in the config menu. Thanks @BuZz !

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.