Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SH command using 100% CPU



  • Noticed that my Rpi3 was running hot all the time. 72 degrees celsius in standby.

    Checked TOP and saw that SH is using 100% CPU.

    Cat'd the process and this is what I found:

    /bin/sh-cwhile true; do for mac in ; do hcitool con | grep -q "$mac" || echo "connect $mac" | bluetoothctl >/dev/null 2>&1; sleep 10; done; done

    I have a bluetooth PS3 controller sync'd to the Pi.

    All my packages are up to date. Ran the updater and rebooted before posting this.

    Is this a known issue?


  • administrators

    @DNVB you must have enabled the "background connect" mode in the bluetooth settings in retropie-setup, which is not designed for use with ps3 controllers, and is not needed in most cases with other controllers.



  • Yes it was set to background. I'm guessing it should be "default"? I've set the config to default and rebooted. Will run upstairs to check that the controller still works!

    Thanks!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.