Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Trouble configuring with DragonRise Generic USB Joystick



  • I bought these 2 jiu man dragonrise joysticks and i am having a hard time trying to configure them in retropie...the 2 joysticks seem to work well, but every time i try to configure the 8 buttons i have for each joystick and no matter how i configure it, it seems to scramble around the button combinations. so my button 1/2 are configured A/B & when i play an N64 game, it will make the B button my 8 button and the A button my 3 button or something like that. It also doesnt seem to work for MAME even though i turned the player 1 & 2 on to both joysticks in the retroarch settings. I plan on upgrading to 4 players soon and i want to solve this issue before i do this.



  • Reading around the inter webs, it seems that that brand of joystick has general issues in Linux of all flavors. It may be that there is no good solution other than getting a tried and tested controller that is known to work well. Any logitech, xbox360, ps3, and I've tried many generic ps3 controllers without issue.



  • @lostless yeah i have seen some of those reviews, but my joystick works great, its just the buttons that seem to not configure correctly.



  • are they the n64 ones? I have the same ones, and whenever I go into an emulator, the buttons are reversed. (B becomes A, etc)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.