Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Bomberman playable with 16 human (or CPU)



  • Hi,
    I have made that : https://github.com/alexis-puska/lr-multi-bomberman

    Bomberman playable at 16 players, on local : all on the same pi, on lan or internet over 1-16 pi, multi local over lan/internet 1-15 player with 1-15 pi. Best performance is on raspberry pi 3, i need to made some optimization code.

    If someone want to test and say me how is it. it can be compile directly on the pi, for more information look at the readme.md in the repository. its can be played on pi, debian, raspbian, mac os X, fedora, ubuntu, but not on windows... it's a retroarch core.

    You can install it on the default theme on the retropie menu. If you use a differents theme adapt your xml file and name of the theme.

    Alexis.



  • That sounds awesome! Defenitely going to look into that later



  • I miss that you can choose all bonus on the game. Once is not implemented, the glove (throw bombe over wall). this is the last step with the IA (2 level of IA is implemented). I hope you enjoy with this little game, that i have made. I made that for my and my friend, play on local or with internet. With retropie, we only play with 2-5 players. I have implemented the multitap on pix for played Crash Team Racing, but we don't have the require number of player (10 persons for 5 players) and we like a lot super bomberman 3 and super bomberman 4. Tank to reply if you have test and how you find it, that help me to make it better. Alexis



  • Hi @alexis-puska

    I've followed the instructions on https://github.com/alexis-puska/lr-multi-bomberman in order to copy and compile lr-multi-bomberman for a Raspberry Pi 3, however when I try to launch the Bomberman.sh from EmulationStation, it seems to get stuck on "Init sound system" on the black screen.

    It gets past "Init sprite system" and "init font text system".

    Is there anything else I could try, or is there any output that may be useful to you?

    Thanks ever so much!



  • Hi,
    These three line were just for me when i develop this core. Did you have a sound and a red screen with the retroarch logo ? In the launch you get 3 line (sprite, font, sound) this is the initialisation of SDL2 librarie and operation on the sprite of bomberman (generate color for player).
    The game is stuck ? What is your version of retropie ?
    Alexis



  • Hi @alexis-puska ,

    Thanks very much for the response. I do not get any sound and a red screen with the retroarch logo, it is simply a black screen with three lines of white text in the top left corner - "Init sprite system", "init font text system" and "Init sound system". It does not progress any further than this.

    I'm running RetroPie version 4.2.3, fully updated on a Raspberry Pi 3 (not overclocked).

    I followed these steps from your GitHub page:

    sudo apt-get update
    sudo apt-get install -y make libsdl2-dev libsdl2-image-dev libsdl2-net-dev libsdl2-ttf-dev libsdl2-mixer-dev libXinerama-dev libXi-dev libXrandr-dev libXss-dev libXCursor-dev
    

    Change the CONF_SWAPSIZE=100 to CONF_SWAPSIZE=200 in /etc/dphys-swapfile

    cd /home/pi/RetroPie/roms
    git clone https://github.com/alexis-puska/lr-multi-bomberman.git
    cd lr-multi-bomberman
    

    Edit Makefile.libretro, changing #platform = rpi to platform = rpi3

    chmod +x Update.sh
    chmod +x Compile\ pi.sh
    chmod +x Bomberman.sh
    ./Compile\ pi.sh
    

    Attempt to launch Bomberman.sh from EmulationStation. It then gets stuck on that screen with the 3 lines of white text.



  • I use retro pie 3.8
    I don't uncomment the plateform line in the makefile.
    Try with this. I download the last version and made a test in the next day



  • Hi @alexis-puska ,

    I've just tried again from scratch and I get the same issue when I haven't altered the Makefile.libretro. Perhaps there are some updates in 4.2.3 which is making this incompatible?

    If there's anything else I can try for you, or any output that may be useful, do please let me know.

    Thanks a lot.



  • Tomorrow (9hours - France) I will buy a new micro sd card, I keep you informed as soon as possible. I will not broke the current install of my arcade cabinet. I make a test and i look why it have a problem. Alexis



  • Thank you ever so much @alexis-puska !!



  • thank's to you, i have develop on a version, test on 3.8, fedora, ubuntu, mac os X, but a configuration create problem, that help me to make some better code. i hope that will works for you in future, and that the game will make you enjoy ;). if it work, we can play together over internet ;)



  • @alexis-puska Absolutely! I love Bomberman, so when I saw you'd done a lr- version with up to 16 players I jumped on it straight away! Hopefully I can assist you getting to the bottom of the problem, and we can both enjoy plenty of multiplayer fun!

    Just let me know when you have another version or method you'd like me to try.

    A little more info, RetroPie is fully updated to 4.2.3, EmulationStation is updated to v2.1.8RP and I'm fully updated with sudo apt-get update and sudo apt-get upgrade. Any other info you need, just ask.

    Thanks.



  • @sonicsheppard
    Hi,
    I buy a new SD card and i test it with a new clean and fresh install. I found something with the SDL2_mixer library. I don't know why i can't use the SDL_openaudio function and why this one stuck the game loading. I push some code on github. for the moment the game launch but they have no any sound played (SDL2_mixer function not executed). I think that in this version of retropie, they have the minimal audio driver installed, and a missing driver is required. Sorry for that you can play but no sound for the moment, i take a look in this week-end. Alexis



  • Hi @alexis-puska ,

    Just tried this from scratch again with your update, and am happy to confirm that it's now loading into game! Looks great and runs really well!

    It is missing sound though, as you explained.

    Let me know if there are any other updates you want me to try whenever yo have something.

    Thanks!



  • 4 hours of reflexion and debug, MIX_OpenAudio() is stuck when call. I don't know why on this specific version of raspbian. i don't know what is the difference in retropie parameter, i need to search. I hope that you can play and test it. I send a mail to the developer of SDL2_mixer to know if in past they have a similar problem.



  • you don't have to reinstall from scratch, when you are on the lr-multi-bomberman emulation station menu, you can update the git repository whit update line :), after this launch compile pi , and launch bomberman :).



  • I have get some help on the LibSDL forum, i get a methode to debug with GDB, i will debug when i have some time, i hope that i will found something.



  • Great to hear @alexis-puska , if you get something you want me to test out, just let me know. Cheers!



  • @sonicsheppard said in Bomberman playable with 16 human (or CPU):

    ssing sound though, as you explained.
    Let me know if there are any other updates you want me to try whenever yo have something.
    Thanks!

    i don't take time, i start a new project and i have no time to works on this two projects... famillial probleme this last two weeks. did you try with the last version ? you have no sound but it's works. I need to fix this very quick for a better game experience.



  • Hi @alexis-puska , I have not tried an update for over a week now, I'll try it later tonight (UK time). Previously it was working great, but it was missing all audio.

    Very sorry to hear about your family problems, hope everything is ok.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.