@mitu Thank you for this tip! The boot is faster disabling "wait for network" and I don't have this text between splashscreen and emulation station. So, for anybody having buggy bluetooth with 2 PS3 controllers with a Raspberry Pi 3B+ and Retropie, here is a solution: disable wifi with [f4] "rfkill block wifi" disable wifi with @cyperghost 's script: https://retropie.org.uk/forum/topic/19734/enable-disable-wifi-with-rfkill Thanks again everyone, we are going to have fun with my friends! :D