Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Mayflash N64 adapter not working - "not configured"



  • Just getting started with RetroPie. No Linux experience.
    My goal is to get N64 emulation working with the Mayflash adapter. I am able to run a ROM (using Super Mario 64 as my test) and to operate it with a keyboard; however, even when I map the N64 controller before starting the ROM, I get an error message saying "100%: []USB GamePad USB GamePad (121/6265) not configured." at the bottom left of the screen.

    I think this issue is similar to the thread here:
    https://retropie.org.uk/forum/topic/7959/mayflash-n64-controller-adapter-problems-all-buttons-configure-in-es-but-no-config-files-generated-or-saved/2

    I attemped to create an InputAutoCfg.ini file as suggested, and replaced all references to the controller with "USB GamePad USB GamePad" as the thread suggested.

    @LARoehr were you able to get it working?

    Pi Model or other hardware: 3 B
    Power Supply used: 2.5
    RetroPie Version Used: 4.2
    Built From: SD Image from RetroPie website
    USB Devices connected: keyboard, Mayflash N64 adapter with one original N64 controller plugged in
    Controller used: original N64
    Error messages received: "100%: []USB GamePad USB GamePad (121/6265) not configured." appears at bottom left of screen when starting ROM
    Emulator: lr-mupen and mupen have the same issue

    Any ideas?



  • @vtbmw11 lr-mupen sucks. For mupen open up the mupen config file and manually put in all your controls. Also it will use the exit commands from retroarch. Make sure in that config there is an option for using manual or auto controls or none. Make sure you set it to manual otherwise it will overwrite the manual controls.



  • Thanks for the response, but I'm not following. I've opened the mupen64plus.cfg file, which has buttons mapped so I don't think I have to manually put in controls. I have the ability to change Controller Configuration Mode from 2 (Fully Automatic) to 0 (Fully Manual) or 1 (Auto with named SDL Device); it's currently set at 2, should it be 0?

    The SDL Joystick Name is "[]USB GamePad USB GamePad" where the [] is a rectangular character. I think this is a similar problem to the thread I linked, but can't follow how they solved it.



  • @vtbmw11 yes try setting to full manual. Then look at the controls in there. Do they match your n64 controllers configs? If not remap them. Also try both controller ports. Even try unplugging and replugging in the actual controller itself. Do you keep any other controllers plugged in?



  • Setting to full manual doesn't solve the problem. I'm not sure how to check whether they match my N64 Controller's configs, as I haven't been able to get the controller to work in a ROM yet to test it. I've tried both controller ports, and have no other controllers plugged in (other than a keyboard).

    FWIW here is the snippet of my .cfg file that deals with controls (after I tried removing the mysterious character from the front of the controller name):
    [Input-SDL-Control1]

    Mupen64Plus SDL Input Plugin config parameter version number. Please don't change this version number.

    version = 2

    Controller configuration mode: 0=Fully Manual, 1=Auto with named SDL Device, 2=Fully automatic

    mode = 0

    Specifies which joystick is bound to this controller: -1=No joystick, 0 or more= SDL Joystick number

    device = 0

    SDL joystick name (or Keyboard)

    name = "USB GamePad USB GamePad"

    Specifies whether this controller is 'plugged in' to the simulated N64

    plugged = True

    Specifies which type of expansion pak is in the controller: 1=None, 2=Mem pak, 5=Rumble pak

    plugin = 2

    If True, then mouse buttons may be used with this controller

    mouse = False

    Scaling factor for mouse movements. For X, Y axes.

    MouseSensitivity = "2.00,2.00"

    The minimum absolute value of the SDL analog joystick axis to move the N64 controller axis value from 0. For X, Y axes.

    AnalogDeadzone = "100,100"

    An absolute value of the SDL joystick axis >= AnalogPeak will saturate the N64 controller axis value (at 80). For X, Y axes. For each axis, this must be greater than the corresponding AnalogDeadzone value

    AnalogPeak = "20000,20000"

    Digital button configuration mappings

    DPad R = "button(13)"
    DPad L = "button(15)"
    DPad D = "button(14)"
    DPad U = "button(12)"
    Start = "button(9)"
    Z Trig = "button(8)"
    B Button = "button(2)"
    A Button = "button(1)"
    C Button R = "axis(3-)"
    C Button L = "axis(3+)"
    C Button D = "axis(2+)"
    C Button U = "axis(2-)"
    R Trig = "button(7)"
    L Trig = "button(6)"
    Mempak switch = "key(109)"
    Rumblepak switch = "key(114)"

    Analog axis configuration mappings

    X Axis = "axis(0-,0+)"
    Y Axis = "axis(1-,1+)"



  • @vtbmw11 do you have a keyboard or mouse plugged in or other controllers? If you do unplug all of them and try. Some mouse and keyboards can also be detected as a controller.

    if you set up your controller in emulationstation, write down all the numbers it says each button is. Then you can go to commandline and type

    Sudo jstest /dev/input/js0
    

    And press buttons and write down the numbers. Compare those two sets and see if they both match each other and what the mupen config says.



  • The Start button and Z button were switched (should be 8 and 9, was 9 and 8, respectively), so I switched them, but other than that, the ES Configure Input screen matched the jstest which matched the .cfg file.

    I'm still getting the same result, though--each time I open a ROM, it says "[]USB GamePad USB GamePad not configured", and after I exit the ROM my N64 controller no longer works in the menu (until I re-map it in the Configure Input menu).

    @NoOddJob @LARoehr @Furluge @Blubberbernd, can any of you give a few more details on how you solved this in the previous thread?



  • @vtbmw11 I have the same problem and I have bee trying for days to get it to work. I think it's just broken. I' going to try to return the USB adapter as I guess it is not supported.

    I wish there was more of a guide on how exactly everything is supposed to work.
    Like wen you configure the controller in ES it writes to the mupen64plus.cfg or no?
    Should a file be getting generated in:

    /opt/retropie/configs/all/retroarch/autoconfig ?
    theres a config file there for my xbox 360 controller but not for the USB GamePad USB GamePad

    Where does the name USB GamePad USB GamePad come from anyways, (Mine also has the funky character in front of it). Probably some non UTF 8 thing (Or whatever retropie rom is using, as I have no idea what char sets it supports).

    But how does the mupen64plus.cfg even know to recognize "USB GamePad USB GamePad" settings. I need to get a better understanding of how ES and everything is integrated together. I read the wiki, but I must not be grasping something.

    When configuring through ES, my analog stick X axis won't work until I come back to it after working through the other buttons.

    in jtest all the buttons work as expected.



  • @justintoxicated I just got mine partially working--as far as I can tell, it only works with the Glide emulator. I've got more testing to do, but I've been able to play multiple games without a problem following these steps:

    1. downloaded the configuration files linked in the previous thread
    2. edited the files to refer to "USB GamePad USB GamePad" instead of HuiJui or whatever it was before
    3. changed controller mode in the .cfg to 0-Manual
    4. followed @edmaul69's advice above to check the controls [thanks!!!]
      4a) I had to swap the Start and Z controls in one of the files
    5. used a keyboard to navigate the menu and to open the configuration options immediately after starting the ROM
    6. selected the Glide emulator (I've been using the non-HighRes one, haven't tested with the HighRes)

    As of now, the controller doesn't automatically work to navigate the menu, so I've got to keep a keyboard plugged in for that, but it works perfectly in the ROMs (including the joystick working as it should).

    Again, I've still got some testing to do to figure out any limitations of what I've done or any other emulators that it works with, but I'm pumped to have it working at all. Many thanks to the posters in the other thread and @edmaul69 for taking the time.



  • @vtbmw11 said in Mayflash N64 adapter not working - "not configured":

    As of now, the controller doesn't automatically work to navigate the me

    @vtbmw11 said in Mayflash N64 adapter not working - "not configured":

    As of now, the controller doesn't automatically work to navigate the me

    I will give it another go too. I think I'm going to do everything from scratch again...



  • I got mine working as well, the trick, I think was to copy in the ini file (changing the name) and let the config file generate it's own information based on the ini file (device id etc). I did set the number to 0 (full manual) for the controller, but it doesn't seem to matter as it changes back automatically once you launch a mupen64* emulator.

    The controller will only work in mupen64 emulators though, so I may still return the adapter for something better. N64 is SOOOO much better with a real N64 controller though.

    Not sure why this failed for me the first time, I think by taking in the cfg file I corrupted something.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.