Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

GPIO gamecon driver not working



  • I'm trying to use a psx (non analog) controller connected directly to my gpio pin and can't figure out what I'm doing wrong.

    If I understand correctly I should have my pins hooked up as follows

    Raspberry pi 3
    *1 psx data -> gpio4
    *2 psx cmd -> gpio14
    *4 psx ground -> ground 6
    *5 psx 3.3v -> 3v3 p1
    *6 psx select -> gpio15
    *7 psx clock -> gpio 18

    Female psx socket
    And a 4.7k resistor between 3v3 and gpio4

    alt text
    alt text
    alt text

    Exact steps takin to reproduce
    -Fresh image of retropie 4.2 using win32disk imager
    -sudo ./RetroPie-Setup/retropie_setup.sh
    -configuration/wifi/connect
    -Update all installed packages, Yes to underlying os packages
    -perform reboot
    -sudo ./RetroPie-Setup/retropie_setup.sh
    -manage packages/manage driver/gamecon/install from binary
    -perform reboot
    -sudo modprobe gamecon_gpio_rpi map=0,0,7,0,0,0 psx_delay=14
    -jstest /dev/input/js0

    Nothing changes, I have tried a wide range of different settings any ideas?



  • I tried this same system with my PiStation originally, but gave up with it, as I wasn't able to get it working. And the benefits form it are only marginal, so it's simpler to just buy adapter, which works out of the box.



  • @dd-indeed alt text
    Tried that it didn't work with my pi or on non-analog controllers



  • @soulgriever

    Fun fact: I have the same keyboard as you do. :D

    About those adapters, some of them are duds, so you propably need to get another one. Luckily, those are cheap. This is how I made the system with it:

    0_1505578682641_WP_20170706_17_27_12_Pro.jpg

    I desoldered the controller block PCB off and soldered that ribbon cable into the pins straight away (you can pull the pins off the controller ports, so it's easier to work with them). Then I just hooked them up to the correct ports on the adapter, so I can disassemble it again if I need to. It could be, that since you soldered the adapter straight into the controller ports that it damaged the adapter. Also, one thing that you need to know, is that the ports on the adapter are sometimes opposite, the Player 1 on the right and Player 2 on the left, and they're opposite in some models. So you should try them both ways as well. Also, I do remember, that there was some connections on that PCB on the port, that connects the two ports together in one or couple lines, so those need to be separated as well.



  • @dd-indeed as far as the psx connector the pcb has all the connections connected together. I used a utility knife to change that. If I try the usb route again I'll purchase 2 single adapters. However I want to try to get the gpio method to work. It requires less parts and it actually reduces a little bit of stress on the pi cpu. The usb interface updates every 8ms the psx gpio driver updates every 10ms.

    I think I'll try a different port that had an internal pull-up resistor



  • @soulgriever

    Allright, I'll look forward to this.



  • Im putting the gpio issue on hold for the moment as for some reason my adapter magically started working correctly. I plan to revisit it someday as it would reduce costs if I built one of these for someone else but for now its on hold. However my arduino came today and should make for some fun here soon.
    alt text



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.